Error compilation Attiny 85

the first time for me to discut in this forum, since many weeks i tried to resolve an problem but i couldn't do that for this reason i need your helps, please.

my problem about compiltation in attiny85, when i compiled the code ( in attachement file) in Genuino Mega2560 board i don't have any problem.
But when i compliled the same code with attiny 85 board (after change pins) and adding the library Adafruit_Circuit_Playground.h , i had below errors compilations:

In file included from C:\Program Files (x86)\Arduino\libraries\Adafruit_Circuit_Playground/utility/CP_Firmata.h:17:0,

from C:\Program Files (x86)\Arduino\libraries\Adafruit_Circuit_Playground/Adafruit_Circuit_Playground.h:25,

from C:\Program Files (x86)\Arduino\libraries\Adafruit_Circuit_Playground/Adafruit_CircuitPlayground.h:3,

from C:\Users\tgachbar\Documents\Arduino\prgramme_street_light_pins_attiny85_onlyRT_For_F\prgramme_street_light_pins_attiny85_onlyRT_For_F.ino:2:

C:\Program Files (x86)\Arduino\libraries\Adafruit_Circuit_Playground/utility/CP_Boards.h:727:2: error: #error "Please edit CP_Boards.h with a hardware abstraction for this board"

#error "Please edit CP_Boards.h with a hardware abstraction for this board"


my setting board in the attachement fils.

Best regards
thank you.


prgramme_street_light_pins_attiny85_onlyRT_For_F.ino (861 Bytes)

The error means the library is not compatible with the ATtiny85. It may be possible to add a hardware abstraction, as mentioned by the error. It may also be that the Adafruit Circuit Playground library is simply not suitable for use with the ATtiny85. You need to understand that the ATtiny85 is quite limited in resources compared to other Arduino boards.

Your code doesn't even use any of the functions of the Adafruit Circuit Playground library. If you don't plan to use any of the functions of the library, simply delete these lines from your sketch:

#include <Adafruit_CircuitPlayground.h>
#include <Adafruit_Circuit_Playground.h>

and the error will be solved.

Hi pert,

Thanks for your reply but when i delete these lines from my sketch :

#include <Adafruit_CircuitPlayground.h>
#include <Adafruit_Circuit_Playground.h>

I have another errors compilation for attiny85 (see the attachement file).

I added the library wire.h but without success (have always errors) :confused:

May be the problem is the comunication I2C between the RTC3231 and attiny85.

errors_code.txt (11.5 KB)

It looks like the DS3231 library you're using is not compatible with the ATtiny85. You might try some of the other DS3231 libraries to see it you can find one that is.

You'll find this sort of problem is fairly common with the ATtiny85. Since it's not as commonly used, there is less support for it. It is also so limited in resources that some projects are simply unable to support it.

ok pert,
I'm seraching another library of DS3231 compatible with attiny85 and i will inform you of result.

Try this one:

Adafruit sells multiple ATtiny85 boards so there's a good chance they'd make sure their library works with ATtiny85.

i changed the library and by, this sktech compiled correctly for the arduino/Genuino Uno but for the attiny85 i have the errors shown in the attachement file.

i went into the file twi.c for trying to remedy this problem and twi.c , int yhe file i changed these lines but always have same problem :

digitalWrite(SDA, 1); to digitalWrite(SDA, 0);
digitalWrite(SCL, 1); to digitalWrite(SCL, 2);

:frowning: >:( confuse

errors RTCLib.txt (18 KB)

Which sketch are you compiling?

I just compiled the RTClib ds3231 sketch for ATtiny85 and there are no errors.

The cause of your errors is that the wrong Wire library is being used. ATTinyCore comes with its own version of the Wire library but for some reason on your system the Arduino AVR Boards Wire library is being used instead. Perhaps there is something wrong with your installation of ATTinyCore. How did you install it? Which version are you using?

you are right, the installation of ATTinyCore causes a problem,

as you asked me i just verified the library, i had two librarys : ATTiyYCore and ATTinyCore-master in the hardware folder , when i delete the first one my sketch compiled correctly (bingo...)

thank you very much pert for your help.


You're very welcome. I'm so glad to hear it's working now. Enjoy!