Error compiling blank sketch- problem started today

Hi, I tried to compile the blink sketch and it threw this error. I tried a blank sketch and it threw the same error. I tried a sketch that was working a few days ago on a teensy 3.5 and it threw the same error. I am not aware of anything that has changed, so I am at a complete loss. Here is the verbose output. Does anyone have any clue whats going on?

Arduino: 1.8.10 (Mac OS X), TD: 1.48, Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

/Applications/Arduino-2.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware /Applications/Arduino-2.app/Contents/Java/hardware -hardware /Users/michaelainley/Library/Arduino15/packages -tools /Applications/Arduino-2.app/Contents/Java/tools-builder -tools /Applications/Arduino-2.app/Contents/Java/hardware/tools/avr -tools /Users/michaelainley/Library/Arduino15/packages -built-in-libraries /Applications/Arduino-2.app/Contents/Java/libraries -libraries /Users/michaelainley/Documents/Arduino/libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10810 -build-path /var/folders/wq/sphf4rmn3hgfffyktkqdv0zc0000gn/T/arduino_build_507725 -warnings=default -build-cache /var/folders/wq/sphf4rmn3hgfffyktkqdv0zc0000gn/T/arduino_cache_819818 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=/Users/michaelainley/Library/Arduino15/packages/arduino/tools/avr-gcc/7.3.0-atmel3.6.1-arduino5 -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino5.path=/Users/michaelainley/Library/Arduino15/packages/arduino/tools/avr-gcc/7.3.0-atmel3.6.1-arduino5 -prefs=runtime.tools.avrdude.path=/Users/michaelainley/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17 -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=/Users/michaelainley/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17 -prefs=runtime.tools.arduinoOTA.path=/Users/michaelainley/Library/Arduino15/packages/arduino/tools/arduinoOTA/1.3.0 -prefs=runtime.tools.arduinoOTA-1.3.0.path=/Users/michaelainley/Library/Arduino15/packages/arduino/tools/arduinoOTA/1.3.0 -verbose /var/folders/wq/sphf4rmn3hgfffyktkqdv0zc0000gn/T/untitled209061136.tmp/sketch_nov11b/sketch_nov11b.ino
loading libs from /Users/michaelainley/Documents/Arduino/libraries: reading dir /Users/michaelainley/Documents/Arduino/libraries: open /Users/michaelainley/Documents/Arduino/libraries: operation not permitted

Error compiling for board Arduino/Genuino Mega or Mega 2560.