Error compiling for arduino nano rp2040 connect

Today when I tried to upload a WiFiNINA example it told me this:

"/var/folders/hj/wqx5_vdx681fsmlpmvr6wlj40000gp/T/arduino_build_692983/sketch/AnalogReadSerial.ino.cpp -o /dev/null -DARDUINO_LIB_DISCOVERY_PHASE
Alternatives for Arduino.h:
ResolveLibrary(Arduino.h)
-> candidates:
/var/folders/hj/wqx5_vdx681fsmlpmvr6wlj40000gp/T/arduino_build_692983/sketch/AnalogReadSerial.ino.cpp:1:10: fatal error: Arduino.h: No such file or directory
#include <Arduino.h>
^~~~~~~~~~~
compilation terminated.
exit status 1
Error compiling for board Arduino Nano RP2040 Connect."

when I tried doing it with the blink sketch(which I currently had running on the board) I got the same problem.

If I tried compiling it with any other board selected it would work.
what should I do?

Hi @golfball2021. Which operating system are you using? That information will allow me to provide you with more detailed instructions for a possible fix you can try.

I actually solved about ten minutes after I posted the question. There is board data called arduino mbed os boards. it was marked as [DEPRECATED]. when I switched to arduino mbed os nano boards it worked fine. I would appreciate if you took the time to fix arduino mbed os boards. thank you.