Error Compiling for board Arduino Uno

Yes that is all it says-“Error Compiling for board Arduino Uno”

I turned on ‘Verbose Output’ thinking maybe it could provide some insight.(I am a newb so I don’t know what a lot of it does)

Here is what it showed then"

Arduino: 1.8.13 (Windows 10), Board: “Arduino Uno”

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Administrator\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10813 -build-path C:\Users\ADMINI~1\AppData\Local\Temp\arduino_build_620282 -warnings=none -build-cache C:\Users\ADMINI~1\AppData\Local\Temp\arduino_cache_719898 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Administrator\Desktop\arduino\BasicLcd\BasicLcd.ino

Error compiling for board Arduino Uno.

"

This is my code, though all the codes which worked before now give the same error.

#include<LiquidCrystal.h>
LiquidCrystal lcd(2,3,4,5,6,7);

void setup() {
  lcd.begin(16,2);
  lcd.home();
  lcd.print("Hi!!");

}

void loop() {
 

}

Additional insights/backstories:

1.Previously I tried running the servo but didn’t power it through battery and the arduino kept restarting several times before I realised what I had to do.(maybe this helps…)

2.I have a really old PC but it runs Windows 10 and I have been having problems with it lately

I don’t know which info helps but I included all I could so please see if there is anything I can do.

Please follow the advice on posting a programming question given in Read this before posting a programming question

In particular note the advice to Auto format code in the IDE and to use code tags when posting code here

This is certainly a mysterious failure. Normally, the IDE provides some useful output about what went wrong, but this time there is nothing.

Since I have no idea what the problem is, I'll fall back on my "wild guess" mode:


Try restarting your computer.


This sort of error could be caused by your antivirus software. Try TEMPORARILY disabling your antivirus for a single compilation to see if the problem goes away, then turn the antivirus back on. If the problem doesn't occur with the antivirus off you will need to adjust the settings of your antivirus to whitelist the appropriate file, folder, or process so it doesn't interfere with compilation.

Please be cautious about working without an antivirus. This is only about temporarily disabling it for a quick test. If you don't feel comfortable doing that, fine. You can try going straight to configuring the antivirus to whitelist the Arduino software.