Error Compiling for board Sparkfun ProMicro

I have the Sparkfun ProMicro and have been using it successfully for the last few months.
I noticed today that the board being ran by the IDE was the Arduino Yun.
So, I changed it back to what I was originally running, the Sparkfun Pro Micro 3.3V.

Now, when I compile I get the error:

Arduino: 1.6.8 (Mac OS X), Board: "SparkFun Pro Micro, ATmega32U4 (3.3V, 8 MHz)"

Board promicro (platform avr, package SparkFun) is unknown

Error compiling for board SparkFun Pro Micro.

I've tried to completely uninstall the IDE but I cannot seem to get a truly new download. This is because after I delete it and redownload my preferences and boards reappear.

Please Help! Cheers

Have you installed pro micro support correctly?
Did you update the IDE ?
Try removing the arduino folder in documents elsewhere and reinstalling everyhing
-Malhar

Try uninstalling and reinstalling the sparkfun package via board manager.
I don't know where board manager installs are hidden on Mac.

On Mac it’s /Users/(username)/Library/Arduino15

Hi
i have the same issue - on Windows. It worked all the time - but all by sudden - it stops working and shows the same error message.
I already disabled and re-enabled the boards in the boards manager - no change...

regards
Thorsten

Install 1.6.5 and try reinstalling the support for the pro micro
-Malhar

I found the soltion: i had to delete everything in C:\Users\de017504\AppData\Local\Arduino15 - then it could reinstall Sparkfun and all works fine :slight_smile: