error compiling in checked sketches

Hi.
I find that Arduino ISP start compiling with the errors .
It’s my old programs, it was compiled and work in real hardware projects. And it was after some times, while i don’t use arduino projects, but i remark, that windows makes few updates and even changed from 8.1 to 10.

ANd i just try to start edit project, and it compile with error!

I think, that possible arduino board attaced don’t correct?

And find, that it don’t defined as “Duemilanove”, but just as “com3” (before it define it on com7,
So, I try
-reboot
-detach and attach board - nothing happened.

So, I download the new arduino version -nightly.
It’s don’t need to install, if i understright, so, I just install AMD64 drivers (because when tryed to 486, it says that this is for 32bit)

it install OK, but when I start to compile the sample sketch (which is autoload after programs start)

Warning: platform.txt from core 'Arduino AVR Boards' contains deprecated recipe.preproc.macros="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} {preproc.macros.flags} -mmcu={build.mcu} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {includes} "{source_file}", automatically converted to recipe.preproc.macros="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} {preproc.macros.flags} -mmcu={build.mcu} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {includes} "{source_file}" -o "{preprocessed_file_path}". Consider upgrading this core.

would be fine if somebody knows, how to solve the problem?

P.S.
All other are works, for example - serial monitor find the board, and read the data and makes exchange with the board.
Thanks.

anton1o:

Warning: platform.txt from core 'Arduino AVR Boards' contains deprecated recipe.preproc.macros="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} {preproc.macros.flags} -mmcu={build.mcu} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {includes} "{source_file}", automatically converted to recipe.preproc.macros="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} {preproc.macros.flags} -mmcu={build.mcu} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {includes} "{source_file}" -o "{preprocessed_file_path}". Consider upgrading this core.

That warning can be safely ignored. The deprecated recipe is automatically converted to the new recipe so it will cause no problems.

i get this as weel with new install after reinstalling windows 7
Arduino AVR Boards' contains deprecated recipe.preproc.macros="

Which IDE are you using ?

Have you tried updating the CORES in the IDE ?

Open IDE, go to TOOLS, select BOARD MANAGER, If the UPDATE box is shown use it.

If UPDATE box is not shown and you are on an older IDE click MORE INFO and see if there is a newer version.

Also consider updating the IDE. best two versions are 1.6.5 and 1.6.9 (1.6.5 recommended for anyone using ESP boards)

Ballscrewbob:
Which IDE are you using ?

As I say in start topic, these new errors are happened, after I download the new arduino version -nightly.

OUCH the nightly version is only for the brave...or testers and developers.

It can be an unstable version as a read about past IDE versions will tell you.
Basically it is still in BETA and may carry unresolved bugs.

1.6.12 actual RELEASE is the better option.