Error compiling "plugin needed to handle lto object"

Is anybody had this kind of compiling error? I tried to google but nothing. The error happens only on mac os, on windows compiling was ok.

Please do this:

  • File > Preferences > Show verbose output during > compilation(check)
  • Sketch > Verify/Compile
  • After compiling fails you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button.
  • Paste the error messages in a message here using code tags(</> button on the toolbar).

Can't post coz of "The message exceeds the maximum allowed length (9000 characters)."

here:

https://docs.google.com/a/koyl.ru/document/d/1GSbQyyMbASPJfRDj3OoCeXa6XTkxnRZ4mgPCcFRRI9A/edit?usp=sharing

(deleted)

Same with V 1.6.9. Actually I got the error on V 1.6.9 and then update to V 1.6.10

Try this:

  • File > New
  • Sketch > Verify/Compile

Does that bare minimum sketch also fail to compile?

teria: Same with V 1.6.9. Actually I got the error on V 1.6.9 and then update to V 1.6.10

Arduino AVR Boards 1.6.12 included with Arduino IDE 1.6.10 uses LTO, which appears to be the cause of this issue. The problem will likely occur if Arduino AVR Boards 1.6.12 is installed in any Arduino IDE version, not just 1.6.10. So you can try to install Arduino AVR Boards 1.6.11 using Boards Manager and be sure to not update from Arduino AVR Boards 1.6.11, even if the IDE shows an updatable boards notification. You can turn the notifications off by File > Preferences > Check for updates at startup(uncheck).

pert: Does that bare minimum sketch also fail to compile? Arduino AVR Boards 1.6.12 included with Arduino IDE 1.6.10 uses LTO, which appears to be the cause of this issue. The problem will likely occur if Arduino AVR Boards 1.6.12 is installed in any Arduino IDE version, not just 1.6.10. So you can try to install Arduino AVR Boards 1.6.11 using Boards Manager and be sure to not update from Arduino AVR Boards 1.6.11, even if the IDE shows an updatable boards notification. You can turn the notifications off by File > Preferences > Check for updates at startup(uncheck).

yea, solved! Thank you! It was problem with AVR Boards!

Thanks! I was having the same problem under openSUSE LEAP 42.2, and reverting to the AVR Boards 1.6.11 fixed it.