error compiling when trying to upload for a 8x8 led matrix

Can anyone help me spot the issue with the code:

#include <Wire.h>
#include “Adafruit_LEDBackpack.h”
#include “Adafruit_GFX.h”

Adafruit_8x8matrix matrix = Adafruit_8x8matrix();

void setup() {
Serial.begin(9600);
Serial.println(“8x8 LED Matrix Test”);

matrix.begin(0x70); // pass in the address

}

static const uint8_t PROGMEM
smile_bmp =
{ B00111100,
B01000010,
B10100101,
B10000001,
B10100101,
B10011001,
B01000010,
B00111100 },
neutral_bmp =
{ B00111100,
B01000010,
B10100101,
B10000001,
B10111101,
B10000001,
B01000010,
B00111100 },
frown_bmp =
{ B00111100,
B01000010,
B10100101,
B10000001,
B10011001,
B10100101,
B01000010,
B00111100 };

void loop() {
matrix.clear();
matrix.drawBitmap(0, 0, smile_bmp, 8, 8, LED_ON);
matrix.writeDisplay();
delay(500);

matrix.clear();
matrix.drawBitmap(0, 0, neutral_bmp, 8, 8, LED_ON);
matrix.writeDisplay();
delay(500);

matrix.clear();
matrix.drawBitmap(0, 0, frown_bmp, 8, 8, LED_ON);
matrix.writeDisplay();
delay(500);

matrix.clear(); // clear display
matrix.drawPixel(0, 0, LED_ON);
matrix.writeDisplay(); // write the changes we just made to the display
delay(500);

matrix.clear();
matrix.drawLine(0,0, 7,7, LED_ON);
matrix.writeDisplay(); // write the changes we just made to the display
delay(500);

matrix.clear();
matrix.drawRect(0,0, 8,8, LED_ON);
matrix.fillRect(2,2, 4,4, LED_ON);
matrix.writeDisplay(); // write the changes we just made to the display
delay(500);

matrix.clear();
matrix.drawCircle(3,3, 3, LED_ON);
matrix.writeDisplay(); // write the changes we just made to the display
delay(500);

matrix.setTextSize(1);
matrix.setTextWrap(false); // we don’t want text to wrap so it scrolls nicely
matrix.setTextColor(LED_ON);
for (int8_t x=0; x>=-36; x–) {
matrix.clear();
matrix.setCursor(x,0);
matrix.print(“Hello”);
matrix.writeDisplay();
delay(100);
}
matrix.setRotation(3);
for (int8_t x=7; x>=-36; x–) {
matrix.clear();
matrix.setCursor(x,0);
matrix.print(“World”);
matrix.writeDisplay();
delay(100);
}
matrix.setRotation(0);
}

When I try and upload it I am getting this error message:

error compiling

/Users/luislinton/Documents/Arduino/libraries/Adafruit_LEDBackpack/Adafruit_LEDBackpack.cpp: In constructor ‘Adafruit_8x16matrix::Adafruit_8x16matrix()’:
/Users/luislinton/Documents/Arduino/libraries/Adafruit_LEDBackpack/Adafruit_LEDBackpack.cpp:298: error: no matching function for call to ‘Adafruit_GFX::Adafruit_GFX(int, int)’
/Users/luislinton/Downloads/Arduino.app/Contents/Resources/Java/libraries/Robot_Control/Adafruit_GFX.h:41: note: candidates are: Adafruit_GFX::Adafruit_GFX(const Adafruit_GFX&)
/Users/luislinton/Downloads/Arduino.app/Contents/Resources/Java/libraries/Robot_Control/Adafruit_GFX.h:41: note: Adafruit_GFX::Adafruit_GFX()
/Users/luislinton/Documents/Arduino/libraries/Adafruit_LEDBackpack/Adafruit_LEDBackpack.cpp: In constructor ‘Adafruit_8x8matrix::Adafruit_8x8matrix()’:
/Users/luislinton/Documents/Arduino/libraries/Adafruit_LEDBackpack/Adafruit_LEDBackpack.cpp:337: error: no matching function for call to ‘Adafruit_GFX::Adafruit_GFX(int, int)’
/Users/luislinton/Downloads/Arduino.app/Contents/Resources/Java/libraries/Robot_Control/Adafruit_GFX.h:41: note: candidates are: Adafruit_GFX::Adafruit_GFX(const Adafruit_GFX&)
/Users/luislinton/Downloads/Arduino.app/Contents/Resources/Java/libraries/Robot_Control/Adafruit_GFX.h:41: note: Adafruit_GFX::Adafruit_GFX()
/Users/luislinton/Documents/Arduino/libraries/Adafruit_LEDBackpack/Adafruit_LEDBackpack.cpp: In constructor ‘Adafruit_BicolorMatrix::Adafruit_BicolorMatrix()’:
/Users/luislinton/Documents/Arduino/libraries/Adafruit_LEDBackpack/Adafruit_LEDBackpack.cpp:374: error: no matching function for call to ‘Adafruit_GFX::Adafruit_GFX(int, int)’
/Users/luislinton/Downloads/Arduino.app/Contents/Resources/Java/libraries/Robot_Control/Adafruit_GFX.h:41: note: candidates are: Adafruit_GFX::Adafruit_GFX(const Adafruit_GFX&)
/Users/luislinton/Downloads/Arduino.app/Contents/Resources/Java/libraries/Robot_Control/Adafruit_GFX.h:41: note: Adafruit_GFX::Adafruit_GFX()

I can’t seem to pinpoint the issue. Please help! Thanks.

Can you post the library you're using? It is complaining about a line in the constructor in the Adafruit_8x16matrix library, which isn't included in the code you posted.

I have the same issue. The problem is that inside the library Robot Control there is an incompatible version of Adafruit_GFX library. I resolved the problem removing Robot Control library and using this Adrafuit_GFX library GitHub - adafruit/Adafruit-GFX-Library: Adafruit GFX graphics core library, this is the 'core' class that all our other graphics libraries derive from