Error compliling after updated board and libraries.

Hello
I use IDE version 1.6.6 and it couldn't find the new board even i checked the type of the board. I updated the board and libraries that pop-up below the program. Now it can not compile any code even the example code from IDE. What should i do? please help me.
thank you.

Upgrade to Arduino IDE 1.8.2. 1.6.6 was one of the worst IDE versions ever released. Updating the hardware cores can sometimes lead to this problem because the Arduino developers don't bother to test them for backwards compatibility with old IDE versions.