Error confusion

I randomly keep getting errors like these in my code: "avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00" then it keeps repeating this whole error, except changing the number of attempts: attempt 2 of 10, attempt 3 of 10, until 10 of 10. And these errors seem pretty random. When this happens, I always set up the blinky circuit (the simplest), and start uploading, and get this error. My port is correct and my board are correct. My wire is connected to my arduino genuino uno, and I still get these errors seemingly randomly. At school this happened a lot, and my teacher couldn't understand either, and now its happening at home. I even swtich the arduino I'm using with another blank one, and try uploading simplest of code, and I get this error. I have been using arduino for maybe a month now, and this issue has been going on and off now for 4 days. By the way, it happened at school when I was using the PC with the Linux boot, and its happening here on my mac at home (I'm just trying to give as much information to solve this issue, because its really stopping me from using my arduino completely!!!). Please help, the sooner I get an answer, the sooner I can start my daily arduino work. Thanks so much for your solution :)

Have you tried different USB cables?

If you are using Arduino IDE 1.6.8, try switching to 1.6.5, faced a similar problem a while back..

Yes, I have used different cables, both at school and at home, it didn’t do the trick, and I’m using Arduino 1.6.9 at home, but at school, i forget which arduino IDE I used. Thanks for the ideas, but I still need a solution

So switching the IDE, didnt work??

Installing a different IDE (I installed 1.6.5 as you suggested Chaitanya1 and uploaded the simplest of codes) did not work. I really appreciate your help and suggestions Chaitanya1, but I would like to know what the error means, so that maybe we can target a solution in a more direct and logical fashion, rather than haphazard guessing. Once again, thanks so much for your help :)

The error means that instead of getting the expected response from the board when trying to upload, it got 0x00 (this typically suggests that there’s no communication at all.

Try the loopback test to make sure the serial adapter isn’t damaged - see instruction in sticky thread here.

When you press the reset button on the board, do you see anything? LED should blink a distinctive pattern (I think 3 blinks on stock Uno).

Is anything connected to pins 0 or 1 or reset? 0 and 1 are used for uploading (as well as serial monitor) so you need those pins free when uploading. If there’s something loading reset pin, that will also break uploads by breaking autoreset (or if it’s grounding reset, by keeping the chip from leaving reset state at all).

Note that responses other than 0x00 - particularly if they’re the same every time - can indicate that the wrong bootloader is on the chip.

1) What is loopback test? My serial adapter is definetely not damaged because when i connect it, the lights on the LED lightup, and I have used several different adaptors, as we discussed before your post. What is sticky thread? and where is it, you said here, where??!!? 2) Yes, the reset button does make that distinct pattern of the LED's, and the lights on the arduino itself. 3)Pins 0 and 1 aren't connected to anything, but what is the reset pin? 4)What is a bootloader?

If you read my initial post about this error, you may have seen that I said that I have only been using for about one month now, I'm very new and unexperienced to this all, so when you use words like boot loader, I completely don't understand:(. I appreciate your help, just explain those things you suggested, so that I can try them, and see if they do the trick :). The sooner I get this done, the sooner I can get back to my regular arduino programming, because this is a legit Donald Trump wall thats not letting me use the arduino that I paid with my honest, hard earned money!!!!

A "Sticky" thread is one that the moderators have made "stick" to the top of the forum, so that people will see them, because they contain important information. Try the one that says "loopback test instructions"..

http://forum.arduino.cc/index.php?board=2.0

2) Okay, so the bootloader is present on the chip and runs when it is reset. Does it do the blink when you are attempting to upload, or not?

3) The pin labeled "RST" or "reset" on the board.

4) A program loaded into the flash (normally at the end, opposite where user code starts) that allows you to upload over serial (as opposed to uploading using an ISP programmer). This comes pre-loaded on Arduino boards, but occasionally you see a post where someone somehow managed to do something bad to it.

I read your initial post, and I see that it was previously working - that's why I'm asking if anything was connected to anything. Otherwise I'd be going through a different set of questions.

Do the loopback test, and report results.

Do you have access to a volt meter? If so, do you actually have 5v on the 5v pin?