Error downloading http://digistump.com/package_digistump_index.json

Hello all,

I searched the forum, but seems like nobody is having this problem.
I have been getting this error msg in Arduino IDE for some time now:

Error downloading http://digistump.com/package_digistump_index.json

Digistump boards have disappeared from the board list and and “Digistump AVR Boards” is gone from boards manager/contributed.

I have tried deleting and re-writing the URL line from Files/Preferences/Additional Boards Manager ULSs
I have tried adding the redirected URL https://raw.githubusercontent.com/digistump/arduino-boards-index/master/package_digistump_index.json
Both resulted with the “Error downloading…” msg.

Both URL’s open fine in my browser, so I know the json file is there…

What’s going on ??

  • After you get that error, click the “Close” button in the Boards Manager window.
  • Click on the black console window at the bottom of the Arduino IDE window.
  • Press “Ctrl + A”. This will select all the text in the console window.
  • Press “Ctrl + C”. This will copy the selected text to the clipboard.
  • In a reply here, click the </> button on the forum toolbar. This will insert code tags into the reply field.
  • Press “Ctrl + V”. This will paste the copied text from the clipboard between the code tags.
  • Click “Post”.

I know how to copy text, and how to paste it properly in a forum. I posted one line only because what you see is the only line of the error msg. There are no other lines in the console that are scrolled up under the editor. I know how to resize the console window and I know how to scroll up too. The error message is one line and that line is pasted in my original post. Thank you for your very detailed select - copy - paste lesson though. Cheers!

BoraY:
I know how to copy text

You'd be amazed at how many people don't. I don't make any assumptions about the skills of people asking for my help. If they already know that stuff, they can just skip over it. You're the first to get offended over it.

I am not offended, maybe just a little bit, that is because you just assumed there were more of that error msg., and I wasn't aware of them. You could have just asked if I could see more info if I scrolled up in the terminal window before explaining me in detail how to do it. Anyhow... I hope someone can comment on my actual problem now. Cheers!

package installs in IDE 1.8.8 on Linux

Juraj:
package installs in IDE 1.8.8 on Linux

Thank you for the info. I am using 1.8.9 on Windows. I have other board definitions on File/Preferences/Additional Boards Manager URL's and they work fine, it seems like there is something wrong with the URL but as I mentioned, I can access the .json file from my browser when I paste the same URL to the address box.

Does anyone know how to make this boards definitions permanent in The IDE rather than constantly loading the .json file from the internet?

I'm having the same issue. I'm using 1.8.9 on Windows, and I encounter an error message in my IDE.

Specifically, "Error downloading https://raw.githubusercontent.com/digistump/arduino-boards-index/master/package_digistump_index.json"

I didn't find any solution for this yet, but I'm hopeful that someone has solved it. This small board would be great if I could get it to work. :slight_smile: Thanks.

Have you tried doubling up the URL ?

Known to occasionally work for some unknown reason.
Best guess is a timing error or cache error or a re-direct (cloudflare etc) of some description.

Eg.

https://raw.githubusercontent.com/digistump/arduino-boards-index/master/package_digistump_index.json,https://raw.githubusercontent.com/digistump/arduino-boards-index/master/package_digistump_index.json

You might also on even more rare occasions need to drop the "S" from "https".

Bob.