Error downloading program

Using usb board and Arduino 003 in Windows I get always the error " Programmer is not responding."

I've tried 9600 and 19200 and external and usb power (changing the power selector)

The Tx blink once but the Rx never light.

If I send a file (using the type comand) to the serial port the TX light until the command finish.

Where can I find the compiled program in order to try to send it directily?

More info, using hyperterminal the TX led blink with each character.


When downloading the program I get the error Programmer is not responding.

I get the same result without the micro in the board.

Maybe the micro hasn't had the bootloader installed?

Have you read the FAQ?

Yes I read it twice before ask ;)

Did you check if there's a bootloader on your chip?

From the FAQ:

"Make sure there's a bootloader burned on the Atmega8 on your Arduino board. To check, connect an LED to pin 13 and reset the board. The LED should blink. If it doesn't, see the Bootloader page ( for instructions on burning a bootloader to the board."

Yes, I've tried it, but I have another working board where the led doesn`t blink after reset but everything works.

The firmware version is 1.18

A bit extranged ::)

You've tried downloading from the same computer to both boards? And one works and one doesn't?

When you changed the baud rate, you did by editing the serial.download_rate in the preferences.txt file, right?

On the board that doesn't work, does an LED on pin 13 blink when you reset the board? How about on the board that does work?

Try swapping the chips between the two boards. That should tell you if it's the chip or the board that's not working. If it's the chip, then it probably need to have a bootloader (or a newer version of the bootloader) burned on it. Or maybe's it just dead. If it's the board itself, you'll need some advice from the Arduino hardware experts (though flipping the board over and checking for bad or loose connections is usually a reasonable way to start).

Thanks a lot, I have found (swapping the micros) that one of the micros is dead.

thanks again

Try to program a bootloader on the "dead" chip

the bootloader now comes packaged with arduino version 3 and if you have access to a PC you can build a very simple parallel port based programmer