Error durig downloading code in Arduino uno R3

I trying to download code in arduino uno but getting same error every time saying,

avrdude: verification error, first mismatch at byte 0x0000 0x0c != 0x62 avrdude: verification error; content mismatch

before this board was running perfectly. Can anyone help me to resolve this issue?

I'd suggest you change the cable usb for one with reasonably retained

Thanks for quick reply... I tried your suggestion of changing USB cable but it is not working.. Looking forward for your help friends!!!

I'd also try to disable and re-enable the com port (device manager) and also on IDE to deselect the com select (pools>port) upload then re-select. Also, try on another machine/os e.g. if your issue is win win8, go to a win7 machine and try

I tried another computer to check arduino board but it is not working. Is this problem related with boot loader? I found some information on internet regarding this problem saying it could be boot loader issue...one more thing is that friend of mine was using board, he said IC got heated just before board stopped working...help please..

It looks like your uno is in bad shape, given it's cost on eBay I'd consider replacing it. Mesnwhile, which IC got heated?

Atmega328P IC got heated...when unknowingly more than 5 V input was given to one of the analog input Pin..

You should find it with preinstalled uno boot loader on ebay and it may be worthwhile to try a replacement before declaring the board unusable

Thank you…I will workout on this solution.

I sorted out that issue...It was problem of bootloader..I replaced atmega328p-pu ic with new ic loaded with bootloader in it..it works fine now..thanks to all who helped me...