Error in "MatrixDisplay 201b 0832 version" library

Ok so i recently got both my Duemilanove and my 0832 led matrix, i went to the miles burton site and downloaded the library for the 0832 version. then i opened it in arduino.exe. everything was going smoothly so i tiried to compile it to the duemilanove and i got a bunch of errors

the line was
MatrixDisplay disp(1,11,10, true); it highlighted it after it gave me some errors.

errors it gave me were

RollingDemo.cpp:1:27: error: MatrixDisplay.h: No such file or directory
RollingDemo.cpp:2:28: error: DisplayToolbox.h: No such file or directory
RollingDemo.cpp:3:18: error: font.h: No such file or directory
RollingDemo:18: error: 'MatrixDisplay' does not name a type
RollingDemo:20: error: 'DisplayToolbox' does not name a type
RollingDemo.cpp: In function 'void setup()':
RollingDemo:28: error: 'disp' was not declared in this scope
RollingDemo.cpp: In function 'void demo_life()':
RollingDemo:62: error: 'toolbox' was not declared in this scope
RollingDemo:71: error: 'disp' was not declared in this scope
RollingDemo.cpp: In function 'void demo_bouncyline()':
RollingDemo:128: error: 'disp' was not declared in this scope
RollingDemo:138: error: 'toolbox' was not declared in this scope
RollingDemo.cpp: In function 'void demoText()':
RollingDemo:208: error: 'disp' was not declared in this scope
RollingDemo.cpp: In function 'void demoBouncyCircle()':
RollingDemo:242: error: 'toolbox' was not declared in this scope
RollingDemo:243: error: 'disp' was not declared in this scope
RollingDemo.cpp: In function 'void drawChar(uint8_t, uint8_t, char)':
RollingDemo:272: error: 'myfont' was not declared in this scope
RollingDemo:272: error: 'pgm_read_byte_near' was not declared in this scope
RollingDemo:275: error: 'toolbox' was not declared in this scope
RollingDemo:277: error: 'toolbox' was not declared in this scope

i guess the library isnt finding those files even though i followed the isntrucions and extracted the file into the library:matrix folder. is there some other place where these should be? please help

,zac :0 :0 :disappointed_relieved:

ok now i have a new error after trying something else.
i moved all of the .h files into the folder with the RollingDemo.pde to see what would happen because it was saying they didnt exist and i got a new error, i will post a picture of my screen. i have all oh .h files open including matrixdisplay.h

the error code is

In file included from RollingDemo.cpp:2:
/DisplayToolbox.h:31:27: error: MatrixDisplay.h: No such file or directory

HELP!!! i dont know what to do, i just want to test if my led board even works!!! any advice?

i went to the miles burton site

Which site would that be?

PaulS:

i went to the miles burton site

Which site would that be?

http://milesburton.com/index.php/Arduino_%26_the_Sure_2416_Information_Display

I downloaded the zip file, unzipped it in the proper place, opened the RollingDemo sketch, and compiled, with no errors, on Win7 64 bit. What OS are you using, and which version of the IDE? Where did you unzip the file to?

win7 ide 0018 and into the library -> Matrix folder