Error mesage

I did simple projects on version 1.2,
I need to do a project, I downloaded 1.6.8 but I cant compile anything on it
I use XP 3rd edition 32 bit, even the samples from help or library gives this error
Exit status 1

The full code is

Arduino: 1.6.8 (Windows XP), Board: "Arduino/Genuino Uno"

D:\Arduino\arduino-builder -dump-prefs -logger=machine -hardware "D:\Arduino\hardware" -tools "D:\Arduino\tools-builder" -tools "D:\Arduino\hardware\tools\avr" -built-in-libraries "D:\Arduino\libraries" -libraries "D:\Arduino\0My proj\libraries" -fqbn=arduino:avr:uno -ide-version=10608 -build-path "C:\DOCUME~1\Admin\LOCALS~1\Temp\build65823b54d473be38cacbd4f284d362b6.tmp" -warnings=all -prefs=build.warn_data_percentage=75 -verbose "D:\Arduino\0My proj\Car\Car\Car.ino"
D:\Arduino\arduino-builder -compile -logger=machine -hardware "D:\Arduino\hardware" -tools "D:\Arduino\tools-builder" -tools "D:\Arduino\hardware\tools\avr" -built-in-libraries "D:\Arduino\libraries" -libraries "D:\Arduino\0My proj\libraries" -fqbn=arduino:avr:uno -ide-version=10608 -build-path "C:\DOCUME~1\Admin\LOCALS~1\Temp\build65823b54d473be38cacbd4f284d362b6.tmp" -warnings=all -prefs=build.warn_data_percentage=75 -verbose "D:\Arduino\0My proj\Car\Car\Car.ino"
"D:\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-ID:\Arduino\hardware\arduino\avr\cores\arduino" "-ID:\Arduino\hardware\arduino\avr\variants\standard" "C:\DOCUME~1\Admin\LOCALS~1\Temp\build65823b54d473be38cacbd4f284d362b6.tmp\sketch\Car.ino.cpp" -o "nul"
"D:\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-ID:\Arduino\hardware\arduino\avr\cores\arduino" "-ID:\Arduino\hardware\arduino\avr\variants\standard" "C:\DOCUME~1\Admin\LOCALS~1\Temp\build65823b54d473be38cacbd4f284d362b6.tmp\sketch\Car.ino.cpp" -o "nul"
"D:\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-ID:\Arduino\hardware\arduino\avr\cores\arduino" "-ID:\Arduino\hardware\arduino\avr\variants\standard" "C:\DOCUME~1\Admin\LOCALS~1\Temp\build65823b54d473be38cacbd4f284d362b6.tmp\sketch\Car.ino.cpp" -o "C:\DOCUME~1\Admin\LOCALS~1\Temp\build65823b54d473be38cacbd4f284d362b6.tmp\preproc\ctags_target_for_gcc_minus_e.cpp"
exit status 1
Error compiling for board Arduino/Genuino Uno.

Please help

I'm guessing you've switched on the verbose settings to get that many output lines?

There may be some incompatibility (alleged) between XP and 1.6.8 although many have reported total success. To prove it, try installing the last known good build 1.6.5 and try the sample sketches using that.

If you try this please post back here with your results so others can benefit or can help you further.

Thanks very much, you are right.
I re-installed the software again and now it works fine.
Best regards

Hi,
It is me again but this time I am lost,
The above errors were with made in china board, a simple software to trig US sensor, if no object, it increments a & segment, and after count 4 it turns on the motor.
Suddenly I got an error
overriding the 115200
avrdude :stk500_getsync() attempt 1 of 10 not in sync : resp=0x86
and repeates to 10 of 10 with different resp numbers,then avrdude done thankyou
and the software does not seem to upload
I deleted all code for the motor still at count of 5 starts!!!!???
I said I deserve it so I got a new Made in ITALY board
still the same and the motor runs
I copied the zip 1.6.5r5 , put back the 1.6.8, tried all the programmers on the list (neither the parallel nor the brand named ones) but still that same error
I have AVERA and AVG, disabled AVG but nothing happened, that same error

OK, let’s start at the beginning.

What is it you are trying to do? Describe the goal of your project.

List down all the parts you are using, exactly and if possible post links to a web-page so we can see them.

Are you using an Arduino UNO or some other board (by the way, the ones made in Far East work just as well as the Italian made ones, even if not actually soldered together quite so well, but there is nothing wrong with them). They are not some inferior copy, they follow (more or less) the Arduino open-source design, and allow us to buy them at an affordable rate. That said, buying a couple of things from Arduino.cc is a good thing as it allows them to keep developing new boards.

Post your code here, using the button in the toolbar which looks like this: </> so that your code is formatted lke this:

#define mySpecialPin 19

Do this and post back and we will try and assist. Keep it clear though!

I’ve just re-read your post a few times and if you are using an ultrasound detector look at my video #17 which deals with ultrasonic detectors (and subscribe to my channel as its aimed at beginners just like you).

Thanks very much for help. Sorry for delay but I wanted to do my home work first.
With 1.8.6, I remember the website says USB can drive the unit for programming, however, after a day or more, I found that I need to power the unit through the AC plug. Now with both versions, downloading problem is solves.
With 1.6.8, I wrote the program to check the distance and increment a counter, but as I add the
analogWrite() command a second time, I get this error:
Collect2.exe: error: ld returned 5 exit states
exit status 1
error compiling for board ARDUINO Uno
and stops. till yesterday. Today however it always give this error even with commenting out all analogwrite commands.

As per your advise, I downloaded the zip 1.6.5r5 , with this version, I get a different error as the attached window’s png pops up and the software completes, clicking NO will dismiss it, the software gives this error
invalid liberary found in "D:\ARDUINO…\Libraries\wire library can’t use both ‘src’ and ‘utility’ folders.

the program seems working fine though yet, but I am worried about when I complete the code…

// constants won't change. They're used here to set pin numbers:
const int ClearCount = 0;    
const int IncCount = 1;     
const int buttonP = 2;    
const int buttonPn = 3;     
const int TachoL = 4;   
const int TachoR = 5;    
const int LeftIR = 6;     
const int CenterIR = 7;
const int RightIR = 8;    
const int Rmotor = 9;     
const int Lmotor = 10;      
const int SideEcho = 11;     
const int FrontEcho = 12;     
const int US_trig = 13;      
const int Rsense = A0;    
const int Lsense = A1;  
// variables will change:
word Dist;
byte cnt;
int Rsensor;
int Lsensor;
int RM;
int LM;
//float Dist;

void setup() {
  // initialize pins as an output:
  pinMode(ClearCount, OUTPUT);
  pinMode(IncCount, OUTPUT);
  
  pinMode(TachoL, INPUT);
  pinMode(TachoR, INPUT); 
  pinMode(LeftIR, INPUT);
  pinMode(CenterIR, INPUT);
  pinMode(RightIR, INPUT);
  pinMode(Rmotor, OUTPUT);
  pinMode(Lmotor,OUTPUT);
  pinMode(SideEcho,INPUT);  
  pinMode(FrontEcho,INPUT);
  pinMode(US_trig,OUTPUT);
  digitalWrite(Rmotor, HIGH);               // Stop motors   
  digitalWrite(Lmotor, HIGH);               // Stop motors
  digitalWrite(ClearCount, HIGH);           // clear display
  delayMicroseconds(5);                     // waits for 5 u second 
  digitalWrite(ClearCount, LOW);
  RM=120;
  Dist = 300;
  while (Dist < 75)
    { Dist = pulseIn (FrontEcho,HIGH,1000);
    delay(200);
    }
}

void loop() {  
  digitalWrite(US_trig, HIGH);
  delayMicroseconds(5);                  // waits for 5 u second 
  digitalWrite(US_trig, LOW);
  Dist = pulseIn(FrontEcho, HIGH,1000);
  if (Dist < 10) Uturn();
  Rsensor = analogRead(Rsense);
  Lsensor = analogRead(Lsense);

  if (Rsensor > Lsensor)
    { --RM;}
  else
    { ++RM;}     
  analogWrite(Rmotor,RM);
  analogWrite(Lmotor,120); 
 // analogWrite(Rmotor,RM);
  delay(1000);                  // waits for a second 


}

void Uturn(){
  analogWrite(Rmotor,0);    // stop motor
  analogWrite(Lmotor,0);    // stop motor
}

Thanks very much and best regards…
I appreciate any explanation, comments or help, It may save some time in the following coding…

Error1.png