Error message from ide "Missing 'maintainer' from library"

I'm using a board (Inhaos lcd2000-7775) that uses a library called "LCD-2000-7775" when i try ot compile the test code i get the following error messages

"Arduino: 1.6.8 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware "C:\Program Files (x86)\Arduino\hardware" -hardware "C:\Users\andy\AppData\Local\Arduino15\packages" -tools "C:\Program Files (x86)\Arduino\tools-builder" -tools "C:\Program Files (x86)\Arduino\hardware\tools\avr" -tools "C:\Users\andy\AppData\Local\Arduino15\packages" -built-in-libraries "C:\Program Files (x86)\Arduino\libraries" -libraries "D:\Documents\Arduino\libraries" -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10608 -build-path "C:\Users\andy\AppData\Local\Temp\builde5d7c944dad792cb0eb6d62cc75b1332.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "D:\Documents\Arduino\libraries\LCD_2000_7775\examples\TFTDisplayText_Mega2560\TFTDisplayText_Mega2560.ino"
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware "C:\Program Files (x86)\Arduino\hardware" -hardware "C:\Users\andy\AppData\Local\Arduino15\packages" -tools "C:\Program Files (x86)\Arduino\tools-builder" -tools "C:\Program Files (x86)\Arduino\hardware\tools\avr" -tools "C:\Users\andy\AppData\Local\Arduino15\packages" -built-in-libraries "C:\Program Files (x86)\Arduino\libraries" -libraries "D:\Documents\Arduino\libraries" -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10608 -build-path "C:\Users\andy\AppData\Local\Temp\builde5d7c944dad792cb0eb6d62cc75b1332.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "D:\Documents\Arduino\libraries\LCD_2000_7775\examples\TFTDisplayText_Mega2560\TFTDisplayText_Mega2560.ino"
WARNING: Category '' in library LCD_2000_7775 is not valid. Setting to 'Uncategorized'
WARNING: Category 'Robotic' in library WebServer is not valid. Setting to 'Uncategorized'
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\mega" "C:\Users\andy\AppData\Local\Temp\builde5d7c944dad792cb0eb6d62cc75b1332.tmp\sketch\TFTDisplayText_Mega2560.ino.cpp" -o "nul"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\mega" "-ID:\Documents\Arduino\libraries\LCD_2000_7775\src" "C:\Users\andy\AppData\Local\Temp\builde5d7c944dad792cb0eb6d62cc75b1332.tmp\sketch\TFTDisplayText_Mega2560.ino.cpp" -o "nul"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\mega" "-ID:\Documents\Arduino\libraries\LCD_2000_7775\src" "D:\Documents\Arduino\libraries\LCD_2000_7775\src\LCD_2000_7775.cpp" -o "nul"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\mega" "-ID:\Documents\Arduino\libraries\LCD_2000_7775\src" "D:\Documents\Arduino\libraries\LCD_2000_7775\src\utility\Adafruit_GFX.cpp" -o "nul"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\mega" "-ID:\Documents\Arduino\libraries\LCD_2000_7775\src" "D:\Documents\Arduino\libraries\LCD_2000_7775\src\utility\glcdfont.c" -o "nul"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10608 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\mega" "-ID:\Documents\Arduino\libraries\LCD_2000_7775\src" "C:\Users\andy\AppData\Local\Temp\builde5d7c944dad792cb0eb6d62cc75b1332.tmp\sketch\TFTDisplayText_Mega2560.ino.cpp" -o "nul"
Missing 'maintainer' from library in D:\Documents\Arduino\libraries\LCD_2000_7775
Using library LCD_2000_7775 at version 1.0 in folder: D:\Documents\Arduino\libraries\LCD_2000_7775

Error compiling for board Arduino/Genuino Mega or Mega 2560."

I have searched the arduino site and google for clues, couldn't find a reference , how do i fix this ?
any help much appreciated

Try the manufacturer. It is their library.

Messaged them this afternoon , As it is a compiler error message, it seems logical to ask here too.

A casual glance at your compiler error messages show they all have to do with the library you are using.

Try 1.6.5r5

1.6.6 and onwards are complaining when libraries don't have all the parameters they want you to provide, even when these are unrelated to funtionality - for example, if the maintainer of the library isn't listed roll-eyes.

Solved
Thank you DrAzzy, there were enough clues in your answer to work out that editing the library.properties file and temporarily putting in my own name and email as the author allowed the sketch to compile, there was a further problem that the top level directory for the library directory had both "src" and "Utility" directories , renaming the src directory allowed the library to function.

hi there

I have the same screen and im trying to get it to work with the gamebuino library im getting only one error message.

Arduino: 1.6.7 (Windows 7), Board: "Arduino Duemilanove or Diecimila, ATmega328"

WARNING: Category '' in library LCD_2000_7775 is not valid. Setting to 'Uncategorized'
Missing 'maintainer' from library in C:\Users\duhjoker\Documents\Arduino\libraries\LCD_2000_7775

Error compiling.

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.

still new to coding so I have no idea what to do.

please help

the work round is to edit the library.properties in the LCD_2000_7775 library folder
so that
it reads
"
name=LCD_2000_7775
author= willy wonka
email=willy@wonka.info
sentence=Write, draw and display images on TFT displays
paragraph=This library is compatible with most of the TFT display based on the ST7775 chipset
url=http://arduino.cc/en/Reference/TFTLibrary
architectures=*
version=1.0
dependencies=SPI,SD
core-dependencies=arduino (>=1.5.0)

"

the author and email address used is arbitrary.

Awesome thank you

How do you have your LCD wired to your board.

Google translation

Hello
I indicate that I have in the library LCD_2000_7775
Folder “examples”
Folder “src”
File “keywords”
File "library.properties

I also have the message “WARNING: Category ‘’. LCD_2000_7775 in library is not valid Setting to ‘Uncategorized’”

If I dial the following program, I get the error message

#include <LCD_2000_7775.h>
void setup() {
  // put your setup code here, to run once:
}
void loop() {
  // put your main code here, to run repeatedly:
}

I do not understand what I should do with the information mentioned in post # 7

Thank you to give easy directions to understand by an Arduino beginner and I’m not computer scientist.

But I love Arduino and much searching, we get to do some programs that work

Thanks again

Open the file library.properties with a text editor.
Add the line:

category=Display

Save the file
Restart the Arduino IDE if it's running.

Where did you download the LCD_2000_7775 library from? I'll see if I can get them to fix these issues.

10/06/2016 18:08
Hello
Since librairie.zip LCD_2000_7775 Arduino,
I get in Documents> Arduino> bookstores> LCD_2000_775:
folder examples
folder src
file keywords 1KB
file library.properties 1KB
The only software with which I can open the file library.properties
is openoffice writer (I copy, I open writer, I paste,
I get the block "insert sectio" I click "insert", I get
name = LCD_2000_7775
author = jeremy wood
email=chuckwood0077@yahoo.com
sentence = Write, draw and display pictures on TFT displays
paragraph = This library is compliant with MOST of the TFT
display based on the ST7775 chipset
url = http: //arduino.cc/en/Reference/TFTLibrary
architectures = *
version = 1.0
dependencies = SPI, SD
Arduino core-dependencies = (> = 1.5.0)
Just before the line url = http ...... I insert the line
"Category = Display"
I then "save as"
Documents> Arduino> bookstores> LCD_2000_775
I "library properties already exists", I replace the
I get in "Documents> Arduino> bookstores> LCD_2000_775
file library.properties 11KB (11KB yes and before 1KB)
I close all open software
I open Arduino and I have not "LCD_2000_7775" in the list of libraries
I get the message "Invalid Library found in
C: \ Users \ hop \ Documents \ Arduino \ libraries \ LCD_2000_7775:
Missing 'name' from library '
Before the transformation of "library.properties" I have "LCD_2000_7775" in the list of libraries

I do not understand anything, unless it be when using a text editor, integration with OpenOffice Writer for me because I did not find anything to edit this "terrible file" library.properties

What do you use as a text editor and pouvvez you help me?
It seems there are many people who have problems with this screen and the Arduino UNO board

thanks for your help

There are thousands of different text editor options. I use Notepad++.

I’ve fixed the file for you. Unfortunately the forum won’t let my upload .properties files so I had to change the extension to .txt.

  • Download the attached library.properties.txt
  • Rename the downloaded file library.properties
  • Replace the one you currently have.

Now I’ve answered your questions but you still haven’t answered mine:

pert:
Where did you download the LCD_2000_7775 library from? I’ll see if I can get them to fix these issues.

library.properties.txt (402 Bytes)

Thank you
I have not tried yet.
I think I took the library in LCD-2000-7775 2.0 inch TFT LCD Display,
Released_LCD-2000_Development_Kit_EN_R02_Update with Arduino IDE 1.6.3

I just found also LCD_2000_7775v3.zip
in http://forum.arduino.cc/index.php?topic=426247.0
but I have not read or tried

thanks pert for all the information.
i just got the product and this thread is very useful.
hopefully, i would be able to get the tft working without major problems.