error message

i keep getting the erorror message: c:\arduino-022\hardware\tools\avr\bin\avr-ar: unable to rename "core.a"; reason:Permission denied

it does not matter which code i used. i have tried my cable and board on a separate computer and it works fine. i have already re downloaded the arduino programming environment three separate times. i also tried using the running version form the other system and it came backwith the same error message. i am running an arduino uno with 7 hp on my laptop.

It looks like you have installed the arduino in a place where you do not have read / write permission. So either get a administrator account to give you permission or move it somewhere where you have permission.

i have tried putting it in my documents folder, on my d:\ drive and running from a external harddrive and it will stil not work.

Hold down the Shift key while clicking the Verify button (LH one). You will see a whole lot of stuff like this:

C:\Documents and Settings\Owner\Desktop\arduino-0022\hardware\tools\avr\bin\avr-ar rcs C:\DOCUME~1\Owner\LOCALS~1\Temp\build6087744292440044728.tmp\core.a C:\DOCUME~1\Owner\LOCALS~1\Temp\build6087744292440044728.tmp\WMath.cpp.o

In my case the core.a file was in:

C:\DOCUME~1\Owner\LOCALS~1\Temp\build6087744292440044728.tmp\

Make sure you have write access to that folder (or something similar). (That is, the one shown when you Shift+Click the Verify button, not the one I have).