Error Occurred while Uploading the Sketch - "avrdude"

Hello!

I am trying to run the sample motor program from Arduino - "DCMotorTest" for the Adafruit Motors.

I had it working and successfully programmed the board last week - same board, computer, cable, etc.

However, now when I try and upload the code to the board, this is the following error I get:

Arduino: 1.8.12 (Windows 10), Board: "Arduino Uno"

Sketch uses 4218 bytes (13%) of program storage space. Maximum is 32256 bytes.
Global variables use 518 bytes (25%) of dynamic memory, leaving 1530 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -cstk500v2 -Pusb -Uflash:w:C:\Users\wegmak\AppData\Local\Temp\1\arduino_build_713356/DCMotorTest.ino.hex:i 

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : stk500v2
avrdude: usbdev_open(): did not find any USB device "usb" (0x03eb:0x2104)

avrdude done.  Thank you.

An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Here are the steps I have tried to see what is going on:

  • Try a different board - I have three Arduino Uno boards. I have tried all three and get the same error. Two of the boards the L LED is Solid, the other one it blinks (which is what I think it is supposed to do; I read something about the Bootloader).
  • Try a different USB Cable. I tried two different cables, one which was used when it initially worked and the other was new.
  • Uninstall/Reinstall the Arduino IDE.
  • Check the Serial Port. The serial port it is plugged into corresponds to the one listed in device manager, and is selected in the IDE under Tools > Port

I'm kind of at a point where I don't know what else to try. I have read multiple forums and tried the suggestions but have not been successful in those attempts. My next try was going to be purchasing a new Arduino Uno, which I'm not sure if that would help.

Thanks! :slight_smile:

You’re doing an “Upload Using Programmer”. This means you either held the Shift key while clicking the “Upload” button, used the Sketch > Upload Using Programmer menu option or used the Shift + Ctrl + U keyboard shortcut.

Do a standard upload.