Error on executing the Arduino IDE on Manjaro Linux 18.0.1

Hello everyone! I’m using the Manjaro 18.0.1 Deepin on my notebook and I’m having some errors to run the Arduino IDE:

(java:1532): Gtk-WARNING **: 17:58:21.115: Unable to locate theme engine in module_path: "adwaita",

(java:1532): Gtk-WARNING **: 17:58:21.116: Unable to locate theme engine in module_path: "adwaita",

(java:1532): Gtk-WARNING **: 17:58:21.120: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.121: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.121: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.122: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.123: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.123: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.123: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.124: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.124: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.124: Unable to locate theme engine in module_path: "murrine",

(java:1532): Gtk-WARNING **: 17:58:21.124: Unable to locate theme engine in module_path: "murrine",
java.lang.NullPointerException
	at processing.app.BaseNoGui.onBoardOrPortChange(BaseNoGui.java:679)
	at processing.app.Base.onBoardOrPortChange(Base.java:1312)
	at processing.app.Base.<init>(Base.java:282)
	at processing.app.Base.main(Base.java:151)

I’ve already installed the gtk-engine package but it doesn’t seem to work.

Can someone help me fix this, please?

How did you install the IDE?

Be sure to always install it from the download on the Arduino website, not from a package manager - the package manager versions are almost always obsolete, and have often been modified by people who don't know anything about arduino, in ways that result in it not working correctly.

I've installed using the yaourt package manager, I'll try to install it from the official site. Thanks for the help!