error on winxp cygwin1.dll

I have been using arduino fine until recently. It starts up fine but now I can't compile or upload any programs. I get this error message instead:

as.exe - Entry Point Not Found The procedure entry point basename could not be located in the dynamic link library cygwin1.dll

Anyone have similar problems or suggestions to fix this???

help!

Make sure you still have cygwin1.dll in your Arduino directory (or a sub-directory, I can't remember which). Also, if you've recently installed another program that also uses cygwin (like WinAVR), that might be the source of the problem. Apparently, cygwin-compiled programs (like the avr-gcc compiler we use in Arduino) sometimes have problems if you have multiple versions of the DLL on your computer.

I am new to Arduino so forgive me if this is a newbie question. I tried looking for any threads about this issue but could not find anything.

I just downloaded and extracted the arduino alpha 0006 compiler and tried to compile my first blinking LED program. I had cygwin installed in before I got arduino so when I tried to compile the Blinking LED program I keep getting this error


6 [main] ? (3512) C:\Dev\arduino-0006\tools\avr\bin\avr-gcc.exe: *** fatal error - C:\Dev\arduino-0006\tools\avr\bin\avr-gcc.exe: *** system sha
red memory version mismatch detected - 0x75BE0084/0x75BE009C.

This problem is probably due to using incompatible versions of the cygwin DLL.

Search for cygwin1.dll using the Windows Start->Find/Search facility

and delete all but the most recent version. The most recent version should

reside in x:\cygwin\bin, where ‘x’ is the drive on which you have

installed the cygwin distribution. Rebooting is also suggested if you

are unable to find another cygwin DLL.

Couldn’t determine program size: NumberFormatException: For input string: “find”


I don’t want to delete my previous installation of cygwin so what can I do to fix this?

thanks in advance.

won

I deleted the cygwin1.dll in the arduino 0006 folder and copied and pasted the cygwin1.dll from c:\cygwin\bin. after doing this arduino 00006 worked for me.

That did it thanks!!! Sorry if this was a newbie question...I appreciate the quick response ;)

cheers

won