Error report

I am renaming this thread because the subject line was previously wrong. Apologies but I do need advice.

After combining code I obtained through this forum concerning Dallas sensors, I got the following error report.

Arduino: 1.8.1 (Windows 7), Board: "Arduino Nano, ATmega328"

C:\Users\Ado\All Saves\Arduino\Saves\libraries\LiquidCrystal_I2C\I2CIO.cpp:35:26: fatal error: ../Wire/Wire.h: No such file or directory

 #include <../Wire/Wire.h>

                          ^

compilation terminated.

exit status 1
Error compiling for board Arduino Nano.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I do not have the indicated line of code - ‘#include <…/Wire/Wire.h>’ anywhere in the sketch, could it be the library?

Interestingly the same error occurs with all my earlier saves and they were fault free when saved but the code I received from Nick_Pyner doesn’t suffer the same error.

I can send a verbose report but it takes four separate posts.

C:\Users\Ado\All Saves\Arduino\Saves\libraries\LiquidCrystal_I2C\I2CIO.cpp is the file containing the erroneous #include

I can send a verbose report but it takes four separate posts.

If you have an 8 megabyte output file, you have more problems than we can help with.

If you have something smaller than that, use Reply (NOT the Quick Reply field) and attach it using the Additional Options link that looks nothing like a link.

But, the error messages tells you the file that is causing the problem and the line number in that file.

Okay, but the file is in the LCD library, how do I get at it or do I delete it and download again?

By output file, do you mean the sketch itself?

how do I get at it

Navigate to the folder where it is stored.

I'm guessing that you are using a Mac, though, there they "help" you by hiding all that "crap". If you are, I can't help you. Haven't even opened my Mac in months. Not sure I even remember my password.

No, I haven't a Mac and a nice load of crap is always interesting isn't it?

So, I found it. Changing the line to #include<Wire.h> did the trick but how did the error creep into a library file?

how did the error creep into a library file?

Presumably the author of the library had Wire.h where the library could find it.

That library was written with the foolish assumption that the Wire library would always be in a specific location in relation to the LiquidCrystal_I2C library, which has caused no end of troubles over the years.