Error trying to burn bootloader to Arduino UNO.

I am having issues uploading sketches to my Arduino UNO. I get the dreaded avrdude issue. I tried to follow the instructions on how to use an arduino board to burn the bootloader. I am hoping that I did not fry my Arduino UNO.

I was trying to use a motor controller board. The issue happened after I did the following:
connected the arduino 5v to the boards 5v (as well as GND). Then, I connected the motor controller’s boards other side to 5v or 12v, I honestly can’t remember. I was under the impression that if you connected those pins to a power source, it would use that source to power the motors. I have included some photos of the motor controller board.

This “other side” is where you connect the motors. it has pins:

2x Motor B
5v
GND
VMS
2x Motor A

I did the following.

Macbook Pro with Catalina OSX (also tried on the latest Raspbian on ras.pi 4.)
Arduino IDE: 1.8.10
Programmer: Seeduino v3.0
Target: Arduino UNO

PINS
programmer  :  target
10  : reset
11  : 11
12  : 12
13  : 13
5v  : 5v
GND : GND

I uploaded the ArduinoISP sketch to the Seeduino.
I then selected “Arduino as ISP” (note, I somehow had 2 showing up in the list)
I then selected burn.

I made a video to display my issue: https://youtu.be/jxNUGl1wv9k

Here is an output of the verbose error:

Arduino: 1.8.10 (Mac OS X), Board: "Seeeduino V3.0(Atmega328P)"

/Users/ssanchez/Library/Arduino15/packages/Seeeduino/tools/avrdude/6.3.0-arduino17/bin/avrdude -C/Users/ssanchez/Library/Arduino15/packages/Seeeduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -cstk500v1 -P/dev/cu.usbserial-A5029TPB -b19200 -e -Ulock:w:0x3f:m -Uefuse:w:0x05:m -Uhfuse:w:0xda:m -Ulfuse:w:0xff:m 

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/Users/ssanchez/Library/Arduino15/packages/Seeeduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf"
         User configuration file is "/Users/ssanchez/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/cu.usbserial-A5029TPB
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 19200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x15
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x15
         AVR Part                      : ATmega328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : STK500
         Description     : Atmel STK500 Version 1.x firmware

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x02

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x10
         Hardware Version: 18036027
         Firmware Version: -290475856.32766
         Topcard         : STK502
         Vtarget         : 1.8 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

avrdude: stk500_initialize(): (b) protocol error, expect=0x10, resp=0x01
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x10

avrdude done.  Thank you.

Error while burning bootloader.

I have also tried using anLafvin Nano (nano clone). using this pin layout.
http://www.bauwe.nl/page/new-bootloader-on-atmega328

I have also tried selecting "arduino uno" as the board and then "burn bootloader".
Another thing I tried was uncommenting the "USE_OLD_STYLE_WIRING" and uploading that sketch to the programmer.

nothing seems to work.