Error uploading Arduino Uno CH340G

Hi there, a bit of help would greatly be appreciated.

I use clone arduino with CH340G ship, however my driver seems to be installed correctly because when I connect my bord, my Windows 10 pc recognise the new device (see capture). However when I try to upload my code, I get the file not found error.

I have 3 similar chinese boards, and I believe that I have been able to upload on them before (a while ago) when I used to be in Windows 7. But it's the first time I try since I pass to Windows 10.

When I connect via USB, 2 of my board give me 2 stable LED (ON, L) and 1 red blinking LED (L).
The last one do show one stable red LED (ON) and one red blinking LED (L).

All of them are recognised by my PC and all give me the same error when I tried to upload my code.

Any suggestions?

Thank you,

OS: Windows 10
Arduino board: Chinese CH340G


Sketch uses 2590 bytes (8%) of program storage space. Maximum is 32256 bytes.
Global variables use 52 bytes (2%) of dynamic memory, leaving 1996 bytes for local variables. Maximum is 2048 bytes.
REMOVE/bin/avrdude -C___REMOVE___/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\Papa\AppData\Local\Temp\arduino_build_639258/Servi_Eric.ino.hex:i Cannot run program "REMOVE/bin/avrdude": CreateProcess error=2, Le fichier spécifié est introuvable
at java.lang.ProcessBuilder.start(
at cc.arduino.packages.Uploader.executeUploadCommand(
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
at cc.arduino.UploaderUtils.upload(
Caused by: CreateProcess error=2, Le fichier spécifié est introuvable
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.(
at java.lang.ProcessImpl.start(
at java.lang.ProcessBuilder.start(
... 8 more
An error occurred while uploading the sketch



Not sure if I can help but where does that REMOVE come from? Looks like it can't find the avrdude application.

That's a good question, but I have no clue what it mean. I'll search around and see if I find something.

Uninstall IDE, delete arduino15 folder, reinstall IDE.

On Mac OS X:

On Windows:
Arduino IDE 1.6.5r5 and previous:
Arduino IDE 1.6.6 and later:

On Linux:
/home/(username)/.arduino15 (a.k.a. ~/.arduino15)

That happens when something mysterious goes wrong with board manager; for reasons unclear to me, it can end up pointing to a bogus location for avrdude.

If not using latest released version of the IDE, reinstall with that.

Thanks DraZzy, that was it!

I deleted the folder

but never found

I didn't have to reinstall, just recompile and upload, et voila!