Error uploading on Arduino that it was working fine before

Hello everyone,

I started to work with Arduino and uploading some simple codes from inventors kit. It was working fine but now I cannot upload any code on it. I reviewed some topics in this forum and tested some solutions but still not working. I am getting this error:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x72

I disconnected every cable from it except usb cable.
The LED beside port 13 is blinking normally during reset and even when I start uploading its blinking and then remains on it mean there is a connection between laptop and Arduino.
The previous uploaded code is still working fine.
I am using Windows 10 64bit and Arduino UNO
The Previous code is about Autonomous vehicle in task 5 inventors kit.

I have no idea about this issue…

Make sure you have Tools > Board > Arduino/Genuino Uno selected.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don’t know which port is your Arduino, you can find it like this:

  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

I did it, still not working. the port is right :frowning:

Chances are that your board has been subjected to conditions outside its maximum ratings, causing permanent damage, and thus will need to be replaced.

As a last resort, you could try burning the bootloader, but it is very rare that this will fix a board:

Thanks :frowning: . I will try bootloader but I think I need another Arduino for it, correct?

You need an ISP programmer. That could be another Arduino use as an "Arduino as ISP" or it could be a dedicated ISP programmer like the USBasp. If you have a dedicated programmer, the procedure is slightly different from what is shown in the tutorial I linked from my last reply so I can provide instructions specific to your programmer if needed.

I dont have none of them. Thanks for your time

That is a very strange way for a previously working board to fail, especially if it's genuine - genuine boards, when they fail, almost always fail to USB not detecting (the 16u2 used as usb interface is the weakest link)