error uploding on board Lambda

error messages :
Arduino: 1.8.5 (Windows 8.1), Board: “LAMBDA (Lite/Basic/Plus)”

In file included from C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:35:0:

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\config/AltSoftSerial_Boards.h:136:2: error: #error “Please define your board timer and pins”

#error “Please define your board timer and pins”

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp: In static member function ‘static void AltSoftSerial::init(uint32_t)’:

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:74:27: error: ‘CONFIG_TIMER_NOPRESCALE’ was not declared in this scope

CONFIG_TIMER_NOPRESCALE();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:79:28: error: ‘CONFIG_TIMER_PRESCALE_8’ was not declared in this scope

CONFIG_TIMER_PRESCALE_8();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:104:10: error: ‘INPUT_CAPTURE_PIN’ was not declared in this scope

pinMode(INPUT_CAPTURE_PIN, INPUT_PULLUP);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:105:15: error: ‘OUTPUT_COMPARE_A_PIN’ was not declared in this scope

digitalWrite(OUTPUT_COMPARE_A_PIN, HIGH);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:113:27: error: ‘ENABLE_INT_INPUT_CAPTURE’ was not declared in this scope

ENABLE_INT_INPUT_CAPTURE();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp: In static member function ‘static void AltSoftSerial::end()’:

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:118:24: error: ‘DISABLE_INT_COMPARE_B’ was not declared in this scope

DISABLE_INT_COMPARE_B();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:119:28: error: ‘DISABLE_INT_INPUT_CAPTURE’ was not declared in this scope

DISABLE_INT_INPUT_CAPTURE();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:122:24: error: ‘DISABLE_INT_COMPARE_A’ was not declared in this scope

DISABLE_INT_COMPARE_A();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp: In static member function ‘static void AltSoftSerial::writeByte(uint8_t)’:

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:147:24: error: ‘ENABLE_INT_COMPARE_A’ was not declared in this scope

ENABLE_INT_COMPARE_A();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:148:22: error: ‘CONFIG_MATCH_CLEAR’ was not declared in this scope

CONFIG_MATCH_CLEAR();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:149:33: error: ‘GET_TIMER_COUNT’ was not declared in this scope

SET_COMPARE_A(GET_TIMER_COUNT() + 16);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:149:39: error: ‘SET_COMPARE_A’ was not declared in this scope

SET_COMPARE_A(GET_TIMER_COUNT() + 16);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp: In function ‘void COMPARE_A_INTERRUPT()’:

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:162:25: error: ‘GET_COMPARE_A’ was not declared in this scope

target = GET_COMPARE_A();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:173:22: error: ‘CONFIG_MATCH_SET’ was not declared in this scope

CONFIG_MATCH_SET();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:175:24: error: ‘CONFIG_MATCH_CLEAR’ was not declared in this scope

CONFIG_MATCH_CLEAR();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:177:24: error: ‘SET_COMPARE_A’ was not declared in this scope

SET_COMPARE_A(target);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:191:40: error: ‘SET_COMPARE_A’ was not declared in this scope

SET_COMPARE_A(target + ticks_per_bit);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:194:24: error: ‘CONFIG_MATCH_NORMAL’ was not declared in this scope

CONFIG_MATCH_NORMAL();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:195:26: error: ‘DISABLE_INT_COMPARE_A’ was not declared in this scope

DISABLE_INT_COMPARE_A();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:202:22: error: ‘CONFIG_MATCH_CLEAR’ was not declared in this scope

CONFIG_MATCH_CLEAR();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:204:40: error: ‘SET_COMPARE_A’ was not declared in this scope

SET_COMPARE_A(target + ticks_per_bit);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:206:34: error: ‘GET_TIMER_COUNT’ was not declared in this scope

SET_COMPARE_A(GET_TIMER_COUNT() + 16);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:206:40: error: ‘SET_COMPARE_A’ was not declared in this scope

SET_COMPARE_A(GET_TIMER_COUNT() + 16);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp: In function ‘void CAPTURE_INTERRUPT()’:

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:228:30: error: ‘GET_INPUT_CAPTURE’ was not declared in this scope

capture = GET_INPUT_CAPTURE();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:231:31: error: ‘CONFIG_CAPTURE_FALLING_EDGE’ was not declared in this scope

CONFIG_CAPTURE_FALLING_EDGE();

^

Multiple libraries were found for “AltSoftSerial.h”
C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:234:30: error: ‘CONFIG_CAPTURE_RISING_EDGE’ was not declared in this scope

Used: C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial
CONFIG_CAPTURE_RISING_EDGE();

Not used: C:\Users\CCS_LP\Documents\Arduino\libraries\AIS_NB_BC95
^

Not used: C:\Program Files (x86)\Arduino\libraries\AIS_NB_BC95-master
C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:241:21: error: ‘SET_COMPARE_B’ was not declared in this scope

SET_COMPARE_B(end);

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:242:25: error: ‘ENABLE_INT_COMPARE_B’ was not declared in this scope

ENABLE_INT_COMPARE_B();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:256:27: error: ‘DISABLE_INT_COMPARE_B’ was not declared in this scope

DISABLE_INT_COMPARE_B();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:263:33: error: ‘CONFIG_CAPTURE_FALLING_EDGE’ was not declared in this scope

CONFIG_CAPTURE_FALLING_EDGE();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp: In function ‘void COMPARE_B_INTERRUPT()’:

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:279:24: error: ‘DISABLE_INT_COMPARE_B’ was not declared in this scope

DISABLE_INT_COMPARE_B();

^

C:\Users\CCS_LP\Documents\Arduino\libraries\AltSoftSerial\AltSoftSerial.cpp:280:30: error: ‘CONFIG_CAPTURE_FALLING_EDGE’ was not declared in this scope

CONFIG_CAPTURE_FALLING_EDGE();

^

exit status 1
Error compiling for board LAMBDA (Lite/Basic/Plus).

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.


If someone have idea.
please help me. :slight_smile: :frowning:

simple_send_IoTtweet.ino (1.38 KB)

It looks like your "LAMBDA" board uses the ATmega328PB:

Apparently the AltSoftSerial library is not compatible with that microcontroller.

You will either need to add support for ATmega328PB the library or else not use it.