Error verifying ALL my code.

Arduino web editor has always worked fine for me, but this afternoon it has suddenly started giving an error when I try to verify my codes, even the most basic. This is extremely frustrating as the same codes had worked fine just a few hours before, and I am working on a time-pressured project. If I switch the selected board/port (from arduino uno, which I have) it works for some. The error is:

''lto1: fatal error: bytecode stream generated with LTO version 3.0 instead of the expected 4.1

compilation terminated.

lto-wrapper: fatal error: ./opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-gcc returned 1 exit status

compilation terminated.

/home/ubuntu/opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld: error: lto-wrapper failed

collect2: error: ld returned 1 exit status

exit status 1''

Any help would be appreciated.

There are multiple other reports of this bug:

I recommend subscribing to those threads so that you'll be sure to get news of any progress in fixing it.

Ok thank you very much. :)

Hello, please follow topic Issue 2018-10-30: lto-wrapper error prevent compilations for further information and updates about this.

Thank you.