Error Verifying Blink Sketch with Web Editor

Hello,

I'm getting the following error when attempting to verify the Blink sketch from the Basic examples Arduino provides. No changes to the code at all.
The error:


In file included from /home/ubuntu/opt/tools/arm-none-eabi-gcc/7-2017q4/arm-none-eabi/include/stdlib.h:11:0,

from /home/ubuntu/opt/tools/arm-none-eabi-gcc/7-2017q4/arm-none-eabi/include/c++/7.2.1/cstdlib:75,

from /home/ubuntu/opt/tools/arm-none-eabi-gcc/7-2017q4/arm-none-eabi/include/c++/7.2.1/stdlib.h:36,

from /home/ubuntu/opt/cores/arduino/sam/cores/arduino/Arduino.h:24,

from /tmp/937610300/build/sketch/Blink.ino.cpp:1:

/home/ubuntu/opt/tools/arm-none-eabi-gcc/7-2017q4/arm-none-eabi/include/stdlib.h:225:8: note: previous declaration 'char* utoa(unsigned int, char*, int)'

char * _EXFUN(utoa,(unsigned, char *, int));

^

exit status 1


I've tried uninstalling and reinstalling the plugin for the Web Editor.
I've tried both the ports on the Due and I get the same error with both. I also get the same error when trying to verify the 'Bare Minimum' sketch via Arduino.
At one point I was able to use the Web Editor to run complex sketches on this same Due, but after attempting to get it to work with the Desktop version of the Editor, failing, then trying to just use the Web Editor again, this error started occurring.
I've spent a fair amount of time googling the error and haven't found a fix.
I've checked driver issues, updating board, etc... Nothing.
The error occurs with every sketch I try.

I also am getting this error which seems to be related. Sometimes I get the one above, sometimes I get the one below:


arm-none-eabi-gcc: error: unrecognized debug output level 'cc'

exit status 1

Although the error message is different, I think this is related to:

In that Arduino Web Editor is using the wrong version of arm-none-eabi-gcc for Due.

I could previously reproduce the error message from arm-none-eabi-gcc but now I get this new error instead. Maybe this means they're working toward a resolution for the problem?

The standard Arduino IDE does not have this problem. If you're having a different problem with it then I'm sure we can help you with that. Fixing problems with the Arduino Web Editor is more a matter of report and wait for Arduino to fix it since we have no ability to do anything ourselves to a cloud based tool.

For future reference, there is a forum section dedicated to the Arduino Web Editor (AKA Arduino Create):

where people knowledgeable on this topic are more likely to see your post. I have requested this thread be moved there.

I see from your edit that you're now getting the error message from http://forum.arduino.cc/index.php?topic=559645, as am I now. Quite strange, but again maybe an indication the Arduino team are tinkering around behind the scenes working on fixing this.

Thanks for the quick response and letting me know about the web editor thread!