error when running arduino script

When I start Arduino script I get the folowing errors

Servo.cpp:1:27: error: avr/interrupt.h: No such file or directory In file included from Servo.cpp:2: /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:28:20: error: avr/io.h: No such file or directory In file included from Servo.cpp:3: Servo.h:24:22: error: inttypes.h: No such file or directory In file included from Servo.cpp:2: /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:101: error: 'uint8_t' does not name a type /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:102: error: 'uint8_t' does not name a type /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:106: error: variable or field 'pinMode' declared void /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:106: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:106: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:107: error: variable or field 'digitalWrite' declared void /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:107: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:107: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:108: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:109: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:110: error: variable or field 'analogReference' declared void /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:110: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:111: error: variable or field 'analogWrite' declared void /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:111: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:111: error: expected primary-expression before 'int' /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:123: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:123: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:123: error: expected primary-expression before 'unsigned' /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:123: error: initializer expression list treated as compound expression /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:125: error: variable or field 'shiftOut' declared void /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:125: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:125: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:125: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:125: error: 'byte' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:127: error: variable or field 'attachInterrupt' declared void /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:127: error: 'uint8_t' was not declared in this scope /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:127: error: expected primary-expression before 'void' /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:127: error: expected primary-expression before 'int' /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:128: error: variable or field 'detachInterrupt' declared void /home/ansmith/Desktop/arduino-0016/hardware/cores/arduino/wiring.h:128: error: 'uint8_t' was not declared in this scope In file included from Servo.cpp:3: Servo.h:29: error: 'uint8_t' does not name a type Servo.h:30: error: 'uint8_t' does not name a type Servo.h:31: error: 'uint8_t' does not name a type Servo.h:32: error: 'uint8_t' does not name a type Servo.h:35: error: 'uint8_t' does not name a type Servo.h:36: error: 'uint8_t' does not name a type Servo.h:39: error: 'uint8_t' does not name a type Servo.h:42: error: 'uint8_t' does not name a type Servo.h:48: error: 'uint8_t' does not name a type Servo.h:49: error: 'uint8_t' does not name a type Servo.cpp:26: error: 'uint8_t' does not name a type Servo.cpp:27: error: 'uint8_t' does not name a type Servo.cpp: In static member function 'static void Servo::seizeTimer1()': Servo.cpp:31: error: 'uint8_t' was not declared in this scope Servo.cpp:31: error: expected ;' before 'oldSREG' Servo.cpp:33: error: 'cli' was not declared in this scope Servo.cpp:34: error: 'TCCR1A' was not declared in this scope Servo.cpp:34: error: 'WGM11' was not declared in this scope Servo.cpp:34: error: '_BV' was not declared in this scope Servo.cpp:35: error: 'TCCR1B' was not declared in this scope Servo.cpp:35: error: 'WGM13' was not declared in this scope Servo.cpp:35: error: 'WGM12' was not declared in this scope Servo.cpp:36: error: 'CS11' was not declared in this scope Servo.cpp:38: error: 'OCR1A' was not declared in this scope Servo.cpp:39: error: 'OCR1B' was not declared in this scope Servo.cpp:40: error: 'ICR1' was not declared in this scope Servo.cpp:46: error: 'TIMSK1' was not declared in this scope Servo.cpp:46: error: 'OCIE1A' was not declared in this scope Servo.cpp:46: error: 'OCIE1B' was not declared in this scope Servo.cpp:46: error: 'TOIE1' was not declared in this scope Servo.cpp:49: error: 'SREG' was not declared in this scope Servo.cpp:49: error: 'oldSREG' was not declared in this scope Servo.cpp: In constructor 'Servo::Servo()': Servo.cpp:56: error: class 'Servo' does not have any field named 'pin' Servo.cpp:56: error: class 'Servo' does not have any field named 'angle' Servo.cpp: At global scope: Servo.cpp:58: error: 'uint8_t' does not name a type Servo.cpp:63: error: 'uint8_t' does not name a type Servo.cpp: In member function 'void Servo::detach()': Servo.cpp:92: error: 'pin' was not declared in this scope Servo.cpp:93: error: 'attached9' was not declared in this scope Servo.cpp:94: error: 'TCCR1A' was not declared in this scope Servo.cpp:94: error: 'COM1A0' was not declared in this scope Servo.cpp:94: error: '_BV' was not declared in this scope Servo.cpp:94: error: 'COM1A1' was not declared in this scope Servo.cpp:95: error: 'pinMode' was not declared in this scope Servo.cpp:98: error: 'pin' was not declared in this scope Servo.cpp:99: error: 'attached10' was not declared in this scope Servo.cpp:100: error: 'TCCR1A' was not declared in this scope Servo.cpp:100: error: 'COM1B0' was not declared in this scope Servo.cpp:100: error: '_BV' was not declared in this scope Servo.cpp:100: error: 'COM1B1' was not declared in this scope Servo.cpp:101: error: 'pinMode' was not declared in this scope Servo.cpp:104: error: 'attached9' was not declared in this scope Servo.cpp:104: error: 'attached10' was not declared in this scope Servo.cpp: In member function 'void Servo::write(int)': Servo.cpp:109: error: 'uint16_t' was not declared in this scope Servo.cpp:109: error: expected;' before 'p' Servo.cpp:113: error: 'angle' was not declared in this scope Servo.cpp:118: error: 'p' was not declared in this scope Servo.cpp:118: error: 'min16' was not declared in this scope Servo.cpp:118: error: 'max16' was not declared in this scope Servo.cpp:119: error: 'pin' was not declared in this scope Servo.cpp:119: error: 'OCR1A' was not declared in this scope Servo.cpp:120: error: 'pin' was not declared in this scope Servo.cpp:120: error: 'OCR1B' was not declared in this scope Servo.cpp: At global scope: Servo.cpp:123: error: 'uint8_t' does not name a type Servo.cpp:128: error: 'uint8_t' does not name a type

I have neither created or edited any sketches or tried to load any sketches . This is afresh install

Try deleting the folder of the IDE and re-downloading the IDE, perhaps it was a screwy download or unpacking of the zip/rar file

figgered it out

I had missed installing "avr-libc"

sudo apt-get install avr-libc

worked like a charm helps to be a little fresher