error when upload Uno R3

hi !

I got trouble with Uno R3, when I write a programe with that include watchdog function that timing 2 secondes to reset automaticly my board (Uno R3). Aftter I uploaded the code to Uno, the led (pin 13) blink, so when I tried to fix my code and then upload again to my Uno, It fail.. So what can I do now ?
I tried alot time but not sucess. MCU atmega328P became brick ?.. Thanks for everybody give me any helpful sugestions.

Does L13 blink 2-3 times very quickly when you press the reset button? And does your computer recognize it? How is it listed in device manager?

PieterP:
Does L13 blink 2-3 times very quickly when you press the reset button? And does your computer recognize it? How is it listed in device manager?

L13 bink very quickly after I upload to arduino uno R3. in fact, I wrote some code to enable watchdog function in my code. But i forget reset or disable watchdog. So I think after I uload this code to Uno R3 it’s always reset automatic My board that’s reason I can’t upload a new code to my Uno R3 again to fix this problem. what should I do now ?

this some lines of code :

#include <avr/wdt.h>

#define LED1 13

void setup()
{

pinMode(LED1, OUTPUT);

wdt_enable(WDTO_4S);
}

void loop()
{

// digitalWrite(LED1, HIGH);
// delay(300);
// digitalWrite(LED1, LOW);
// delay(300);

}

Ok, try this:
Hold down the reset button
Click upload
Let it compile
When it says "Uploading ...", release the reset button

It does'nt work. I did like u said , and I see the Rx led blinks 2 or 3 times but Tx led not respond, IDE show below :

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM4
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you.

Either your ATmega is dead, or the bootloader is corrupted. If you have a second Arduino or an ISP programmer, you can try to burn the bootloader, but if that doesn't work, you'll probably need to buy a new one ...

But don't throw the board away if that's the case, you can still use it as a USB-to-Serial converter, which is extremely handy for debugging or programming other ATmega chips.
You could also buy a new ATmega328P, if you have an Uno with the DIL package.

Hopefully it's just that watchdog timer that screws up the upload, so you can get away with just reflashing the thing.

good morning !. I think it'not death,when I supply power to board via Usb cable etc... I can see L13 blinks very quickly. But when I press on Reset Button L13 stop blinking but It'still light on untill i release reset Button about 2 ..... 4 seconds I start blinking again. in this case I have another Uno U3 board what should i do with main chip(atmega328p) ?.. I tried to reasambly this chip and reflash It with a IPS programmer but the prommer reply this chip is lock and I can't erase the programing inside this chip, maby it's cause fuse bit of chip was setup to protected it by manufacture ? STK500-ISP/HV programmer is good choise for this case , that help reconfig fuse bit of atmega328p then I can refash it normally ?

hi, thanks for ur all reply . I bought a reset fuse avr board and reset chip after that bootloade atmega328p via a second arduino uno R3. the last It can be flash normal. I'm lucky this a lesson to me and someone facing issue like this. thanks a gain.