Error when using arduino CLI or Arduino Vscode MacOS

Hello! I wanted to upgrade from the Arduino IDE for a complex project and now I am having a hard time getting Arduino on VScode working. Failing to do so I wanted to use the Terminal with CLI as an alternative but I found the same error:

loading libs from /Users/username/Documents/Arduino/libraries: reading dir /Users/username/Documents/Arduino/libraries: open /Users/username/Documents/Arduino/libraries: operation not permitted

[Warning] Failed to generate IntelliSense configuration.
[Error] Analyzing sketch 'falcon_arduino/src/falcon_arduino/falcon_arduino.ino': Exit with code=1

I tried everything proposed on Forums:
I changed the configuration of the arduino.json file, I added the Arduino path.
I uninstalled the arduino IDE and reinstalled it.

....... Waw Okay While writing this post I found the right article!
Posting it here for the ones having the same issues:

You should simply grant access to terminal and VScode and this error is solved on MacOS. I could not believe that terminal didn't have Full Disk Access.