Error while uploading: missing 'program.tool' configuration parameter

I am getting:

Error while uploading: missing 'program.tool' configuration parameter

when I try to upload a sketch to an attiny85 via usbtinyasp.
I can't find any reference to "program.tool"; so not sure what I need to do.

Alternatively, I tried using an arduino-as-isp & got the same error.

I have tried using two different tiny cores. David Mellis's core and Spence Konde's core both fail with the same error

Using arduino 1.6.5 rc2 and R5

Any ideas? If feels like something must have gotten corrupted... I re-installing but it didn't help.


When trying to burn using konde's core when "arduino as isp" (works with USPTinyASP)
avrdude: ser_open(): can't open device "\.\com1": The system cannot find the file specified.
I have specified com13,which is correct port...


For what it's worth; I searched for files with "program.tool" and found it in programmers.txt
(snipped other lines)

arduinoasisp.name=Arduino as ISP
arduinoasisp.program.tool=avrdude
usbtinyisp.name=USBtinyISP
usbtinyisp.program.tool=avrdude

You're using IDE 1.6.x with a core that is not compatible with 1.6.x (ie, a 1.0.x core). Install a core that's compatible with 1.6.x and use that.

Take a look at second link in my sig - that's a 1.6.x core that supports the Tiny 85 (and the rest of the x5 series), as well as almost every other tiny available (except the '13, and the ones supported by my other core). That is not a board manager link, it's a link to a page with information.

Thanks Spence. I am at a loss as to how it worked a month ago (why I thought something was corrupted) -- I'll redownload your core....