Error with code

We copied a code from this site, and we're getting the error below from it. We have no idea what it means, or how to fix it. Can someone please help us out, ty. We'll let you know if we find anyway around this, we're gonna keep researching this.

Build options changed, rebuilding all
C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522.cpp: In member function 'bool MFRC522::MIFARE_SetUid(byte*, byte, bool)':

C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522.cpp:1850:39: warning: 'bool MFRC522::MIFARE_OpenUidBackdoor(bool)' is deprecated (declared at C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522.cpp:1706): will move to extra class in next version [-Wdeprecated-declarations]

if (!MIFARE_OpenUidBackdoor(logErrors)) {

^

C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522.cpp: In member function 'bool MFRC522::MIFARE_UnbrickUidSector(bool)':

C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522.cpp:1879:34: warning: 'bool MFRC522::MIFARE_OpenUidBackdoor(bool)' is deprecated (declared at C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522.cpp:1706): will move to extra class in next version [-Wdeprecated-declarations]

MIFARE_OpenUidBackdoor(logErrors);

^

In file included from C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522Extended.cpp:8:0:

C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522Extended.h: In constructor 'MFRC522Extended::MFRC522Extended(uint8_t)':

C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522Extended.h:81:44: warning: 'MFRC522::MFRC522(byte)' is deprecated (declared at C:\Users\Jon L\Documents\Arduino\libraries\MFRC522\src\MFRC522.h:337): use MFRC522(byte chipSelectPin, byte resetPowerDownPin) [-Wdeprecated-declarations]

MFRC522Extended(uint8_t rst) : MFRC522(rst) {};

^

C:\Users\JONL~1\AppData\Local\Temp\cc9cj0EF.ltrans0.ltrans.o: In function `main':

C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino/main.cpp:46: undefined reference to `loop'

collect2.exe: error: ld returned 1 exit status

Multiple libraries were found for "Servo.h"
Used: C:\Users\Jon L\Documents\Arduino\libraries\Servo
Not used: C:\Program Files (x86)\Arduino\libraries\Servo
Multiple libraries were found for "LiquidCrystal.h"
Used: C:\Users\Jon L\Documents\Arduino\libraries\LiquidCrystal
Not used: C:\Program Files (x86)\Arduino\libraries\LiquidCrystal
exit status 1
Error compiling for board Arduino/Genuino Uno.

The first messages are just warnings that you are using parts of the API that will be removed in a later release.
The second part is a linker error: You didn't define the loop function.
Take a look at the examples that come with the IDE. You always need both a setup and a loop function.

Pieter

You don't give much information about the code. Did you copy the one coming just after the sentence "So that’s pretty much everything and here’s the complete code of the project:", and ONLY THAT ? (which is what you are supposed to do...)

@lesept Okay, so we completely missed that code. We were using the one that was separated, dumb mistake on our part. We switched to the one you were referring to, and don't have any problems yet. Thanks for the reply. We'll let you know if anymore problems occur.

Good!