Error with Wireless Camera using Arduino Yun

Hello All,
I am currently in the process of working on an Internet of Things project using the Arduino Yun and would love your help. I am currently in the process of testing the camera capture and loading it onto a MicroSD card. MY MAIN ISSUE is that I cannot reliably test the camera capture in the Hardware Configuration.

The end result of this project is to use a PIR sensor to upload images to a Dropbox account using a standard webcam. The overall project can be found here:
http://www.openhomeautomation.net/wireless-security-camera-arduino-yun/

I can intermittenly snap pictures with the instructions with the above link, but cannot do so reliably. I have made sure that my camera is UVC compatible. I have attached screenshots of the STAT error I am seeing. Is this a result of a bad driver or directory pointer? Any help would be appreciated!

It also appears that my Yun is not seeing my web camera, Logitech QuickCam for Notebooks Pro:http://www.amazon.com/QuickCam-for-Notebooks-Pro-Webcam/dp/B003CJA3KS/ref=sr_1_6?ie=UTF8&qid=1421633293&sr=8-6&keywords=logitech+quickcam+for+notebooks

Here is some additional info that might help:
Yun Firmware version:
OpenWRTYun Attitude Adjustment 1 / LuCI 0.11 Branch (0.11+svn10537)

Kernel/Linux Version:
3.3.8

I am extremely frustrated and would very much appreciate any help other members may contribute!
Thanks!
-MP

Stat error.jpg

lsusb.jpg

You should add powered USB Hub between Yun and Your device

http://forum.arduino.cc/index.php?topic=284254.msg1993792#msg1993792

Make sure you have camera on usb bus.

root@Arduino:~# lsusb
...
Bus 001 Device 007: ID 046d:0829 Logitech, Inc.

UVC camera only:

root@Arduino:~# lsusb -d 046d:0829 -v | grep "14 Video"

If your device is a UVC device, you should see a number of lines that look like this:

bFunctionClass         14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video
      bInterfaceClass        14 Video

Install UVC driver:

opkg update
opkg install kmod-usb-core kmod-video-core kmod-input-core 
opkg install kmod-video-uvc

Confirm driver installed:

root@Arduino:~# lsmod | grep uvc
uvcvideo               57752  0
videobuf2_vmalloc       1585  1 uvcvideo
videobuf2_core         16456  1 uvcvideo
videodev               70150  2 uvcvideo,v4l2_common

Non UVC Camera:

...
Bus 001 Device 007: ID 046d:0829 Logitech, Inc.

046d:0829 = :

form

http://eko.one.pl/?p=openwrt-webcam

get which kmod-video-* driver is needed.

The camera I have is listed here : http://en.wikipedia.org/wiki/List_of_USB_video_class_devices and that link was provided by the instructions found here: http://www.openhomeautomation.net/wireless-security-camera-arduino-yun/

Also is there a directory in which I can see all the drivers installed on my Yun? How do I use the grep command you provided me?

http://en.wikipedia.org/wiki/List_of_USB_video_class_devices

  • These devices also have non-UVC equivalents by the same name. Please check the product number to confirm UVC compatibility.

Use

root@Arduino:~# lsusb -d 046d:0829 -v | grep "14 Video"

to confirm.

You should add powered USB Hub between Yun and Your Camera, It is Yun hardware bug!

http://forum.arduino.cc/index.php?topic=284254.msg1993792#msg1993792

Use

root@Arduino:~# lsusb

to confirm camera on usb bus.

Sonnyyu,
Thank you very much! That worked! I have verified that the OS has recognized the usb hub and the camera. I have also verified that my drivers for fswebcam are current. Unfortunately when I run the fswebcam command, I get a stream error.

Is this because I am pointing to the wrong usb location? I attached a copy of my error.

stream.JPG

Read through

http://forum.arduino.cc/index.php?topic=253571.5