Errors on Arduino-0010 startup Mac

Hi,

I am running OS X 10.4.10 and have been running arduino-0010 for several days. All of a sudden tonight i got this big batch of errors when I start the app for the first time, and then it errors out every time I upload a sketch.

I have re-installed (copied over the old folder replacing everything) and I get the same dump of errors on first start.

Any Ideas?

Here is the error dump:

In file included from /Applications/arduino-0010/hardware/cores/arduino/WConstants.h:1,
from Firmata.cpp:31:
/Applications/arduino-0010/hardware/cores/arduino/wiring.h:60:1: warning: “abs” redefined
In file included from Firmata.cpp:28:
/Applications/arduino-0010/hardware/tools/avr/bin/…/lib/gcc/avr/4.0.2/…/…/…/…/avr/include/stdlib.h:116:1: warning: this is the location of the previous definition
Firmata.cpp: In member function ‘int FirmataClass::available()’:
Firmata.cpp:70: warning: no return statement in function returning non-void
Firmata.cpp:70: warning: control reaches end of non-void function
In file included from /Applications/arduino-0010/hardware/cores/arduino/WProgram.h:6,
from Stepper.cpp:48:
/Applications/arduino-0010/hardware/tools/avr/bin/…/lib/gcc/avr/4.0.2/…/…/…/…/avr/include/avr/signal.h:36:2: warning: #warning “This header file is obsolete. Use <avr/interrupt.h>.”
In file included from /Applications/arduino-0010/hardware/cores/arduino/WProgram.h:8,
from Stepper.cpp:48:
/Applications/arduino-0010/hardware/cores/arduino/wiring.h:60:1: warning: “abs” redefined
In file included from /Applications/arduino-0010/hardware/cores/arduino/WProgram.h:1,
from Stepper.cpp:48:
/Applications/arduino-0010/hardware/tools/avr/bin/…/lib/gcc/avr/4.0.2/…/…/…/…/avr/include/stdlib.h:116:1: warning: this is the location of the previous definition
In file included from utility/twi.c:25:
/Applications/arduino-0010/hardware/tools/avr/bin/…/lib/gcc/avr/4.0.2/…/…/…/…/avr/include/avr/signal.h:36:2: warning: #warning “This header file is obsolete. Use <avr/interrupt.h>.”

::)

OK - part of my problem was that i had a wire in the 1 and 0 pin so now I can upload a sketch. walks away kicking rocks - how embarassing

Those errors on startup are normal (and fine), but not very nice. I'm going to try to get rid of them soon.