Errors while editing code

Win 7, Arduino 1,8,5

I'm a noob but things have been working fine for the first couple of weeks.
Now I keep getting trouble editing and entering code.

I keep finding I can't move the cursor about, and when I click into a different line, odd bits of lines appear or vanish.
Sometimes saving the file and restarting helps, for a while.
There's pages of stuff I don't understand in the "error" window, such as below.

Can anyone help?

at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
at java.awt.Container.dispatchEventImpl(Container.java:2280)
at java.awt.Window.dispatchEventImpl(Window.java:2746)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
at java.awt.EventQueue$4.run(EventQueue.java:731)
at java.awt.EventQueue$4.run(EventQueue.java:729)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Have you tried deleting the software and redownloading it? Make sure the checksum matches so you can check that the file for the IDE downloaded properly. I would also double check that 1.8.5 is compatible with Win 7 or if it would be advantageous to download an earlier version.

If you can't seem to make the software work, perhaps try using the online IDE.

Thanks I'll check those :slight_smile:

I had a similar error when I started using arduino nano. Then it turned out that the reason in the USB2 driver (CH340), after installing the driver, the problem was solved and Arduino IDE also reinstalled))).

I've checked the driver ("xp and up") and reloaded everything.
The problem above is much rarer now but I have others, mostly with intermittent port operation. I'll work for several uploads, them refuse.

Sometimes the little downloaded program (reads 4 pots, writes to 4 servos) (https://www.instructables.com/id/MeArm-Controled-With-Arduino/) is fine, but mostly it's not. There may be a power problem. I'm feeding a 12V 1A supply into the board (while it's also connected to USB). The regulators onboard get quite hot (9V would be better). Do Arduinos shut down if the regulator gets too hot?

It's a Sintron Uno clone.
It's not overloading the 1A ( the servos hardly ever work so not too much current drawn, and the supply is still 12V).

More often than not when I upload a small modification (like a servo limit adjusted narrower) the program appears to do nothing.

Serial.print shows it's not reading the pots, then if it does, it doesn't write to the servos.

Then it'll work for a few minutes
Then it'll say it can't comm via the port , but it'll upload something which sends servos to the end of their travel, then nothing happens at all except Com errors.

"Arduino: 1.8.5 (Windows 7), Board: "Arduino/Genuino Uno"

Sketch uses 3606 bytes (11%) of program storage space. Maximum is 32256 bytes.
Global variables use 266 bytes (12%) of dynamic memory, leaving 1782 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM7 -b115200 -D -Uflash:w:C:\Users\lenlap\AppData\Local\Temp\arduino_build_422291/Potentiometer_servo_control.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM7
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: ser_open(): can't open device "\.\COM7": The system cannot find the file specified.

avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences."

Yes it's COM7 in Device Manager too.
It used to be COM 4, then 5 and 6, but it says they're busy . They aren't.

This is just a rubbish waste of time!

One point - I would not drive 4 servos from the Arduino, that is likely to overload the regulator and shut it down . That may well the source of yr upload problems
When you get problems like this go back to basics .

  • power via usb
    -disconnect and less, switches etc
  • upload the blink example .

If that works then move on .

I’d always advise buying a genuine Arduino UNO as a starting point , with a quality data lead.
Make sure your computer is up to date and virus free , then do a fresh install of the IDE.

When you move on from using blink , if you are not sure research what you need, with google or here.

Hi is this the right bit to ask about a beginner problem?

Thanks Hammy. I was assuming they wouldn't draw significant current unless doing something. I'll try unpugging all but one, and look for an external V reg.

Babylon1:
Hi is this the right bit to ask about a beginner problem?

I think so, as long as it's to do with Installation & T'shooting, but it's always better to start your own post otherwise everyone gets bored & annoyed reading through irrelevant stuff :).