Errror in connecting Arduino UNO

I have a Arduino UNO . I use it with my Windows 10 laptop from over 3 months , when today I connected it to upload a program , what I saw was that , the pc dosent recognized my Arduino board since I have used it many times earlier , jst the previous day .

The beep sound which occurs whenever I connect the board didn't beeped this time and didn't even listed in the port settings of Arduino IDE and when I click to upload the sketch , it gave a error - "avrdude: ser_open(): can't open device "\.\COM3": The system cannot find the file specified."

Then I opened and checked my Device manager ( control panel) there also it was not listed under port and COM settings , nd nor in the unknown devices . I don't have any idea what is wrong with it . Please anyone suggest me how to overcome it .............!!!!!!!!!!!!!!!

Try a different USB port.

Still not showing up in control panel?

Try a different chord.

Still nothing?

Try a different computer.

Still nothing?

Probably time to get a new Arduino.

That's how I would handle it.

Thanks For Your Suggestion , but its still not working . It is working with the previously uploaded code , but not accepting the new one . I think i would get a new one .