ESP-01 Probleme beim Upload

Habe mir einen ESP-01 mit USB Adapter besorgt und meine Arduino IDE für den ESP8266 konfiguriert, mithilfe dieser Anleitung:

Leider komme ich nicht weiter, ich kriege einen Haufen Fehlermeldungen beim Upload, der Test mit dem Seriellen Monitor hat aber funktioniert.

Ich hoffe ihr könnt mir helfen.

Hier mal die Fehlermeldungen:

Arduino: 1.8.1 (Windows 7), Board: "Generic ESP8266 Module, 80 MHz, 40MHz, DIO, 115200, 512K (64K SPIFFS), ck, Disabled, None"

Der Sketch verwendet 222205 Bytes (51%) des Programmspeicherplatzes. Das Maximum sind 434160 Bytes.
Globale Variablen verwenden 31572 Bytes (38%) des dynamischen Speichers, 50348 Bytes für lokale Variablen verbleiben. Das Maximum sind 81920 Bytes.
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
error: failed reading byte
warning: espcomm_send_command: cant receive slip payload data
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

Dieser Bericht wäre detaillierter, wenn die Option
"Ausführliche Ausgabe während der Kompilierung"
in Datei -> Voreinstellungen aktiviert wäre.

Gruß
ESPFriend

mithilfe dieser Anleitung:

Der Anleitung fehlen Kondensatoren.

(mehr habe ich nicht überprüft)

Ich verwende solch einen Adapter:

ESPFriend:
Ich verwende solch einen Adapter:
http://www.komputer.de/zen/cache/images/d/dec5f74b0e61b00613e515617db5f919.image.750x501.JPG

Ach...
Manno!
Sach das doch sofort.....

Der braucht noch einen zusätzlichen Taster zum flashen.

Siehe dazu: ESP8266 tuning

combie:
Ach…
Manno!
Sach das doch sofort…

Der braucht noch einen zusätzlichen Taster zum flashen.

Siehe dazu: ESP8266 tuning

ESPFriend:
Habe mir einen ESP-01 mit USB Adapter besorgt

Hab ich doch :disappointed_relieved:

So hab jetzt mal umgebaut, musste erst mal ne Platine finden wo ein Taster drauf war welche ich nicht mehr brauche, funktioniert perfekt, wenn man so sieht ist dieser Adapter irgendwie ne Fehlkonstruktion, aber mit dem Fix total praktisch
.

!Glückwunsch!

Danke an Combie!
Ich habe mal provisorisch mit einer kleinen spitzen Zange die Pins (GPIO0 und GND) beim Einschalten der Spannung kurzgeschlossen, dann die Zange entfernt. Dann hat das Hochladen mittels der Arduino-Umgebung funktioniert.

Gibt es eigentlich auch ähnliche Adapter (seriell) für den ESP-01, auf denen der Taster gleich drauf ist?

ub60

Ich finde die Dinger klasse!
Und mit 1MByte auch schon OTA fähig.

Bastler freundliches Rastermaß.
Klein.
Kein unnützes Gedöns dran.
Nix.

Leider wenig Pins.
Aber man kann nicht alles haben.

Gibt es eigentlich auch ähnliche Adapter (seriell) für den ESP-01, auf denen der Taster gleich drauf ist?

@combie:
Danke für den Link. Für den Preis löte ich mir wohl doch selbst einen Taster ran :slight_smile: .

ub60