ESP-01 Relay boards found on Ebay

I got 5 of these in yesterday and was rather disappointed to find they didn't work. TBH, I'm not sure if this has been posted here or not, searching for "relay" returns dozens of results, and these don't actually have a real part# on them. But if it hasn't been posted, this what I did to make it work. Much of the path I followed was based upon a youtube video in Russian that I found someone to translate for me.

|500x375

First problem is that CHPD isn't connected to VCC. That was just a simple jumper across the bottom pins. The video shows the jumping them across the ESP-01 board. I just preferred to do it across the bottom.

Second is that the signal out is attached to GPIO0 not GPIO2. I cut the trace and then soldered in a jumper between the far side of the cut and GPIO2.

Third was the board wouldn't boot. This was resolved by soldering a 3.3K resistor from VCC to GPIO2.

The video talks about changing out R1, I did not do this as I found the board worked fine with the above changed. Didn't feel the need to mess around with SMD's if it wasn't necessary.

Now it boots up fine, and the relay functions properly when sent commands from the web.

I am not understanding why you are making all those modifications.

Do you even understand how the ESP-01 module works?

Yes, I do, and it doesn’t work in these boards at all as they come. I can use the exact same program on these board connected to a stand alone relay and they work fine. Plug them into these boards and they don’t. I wouldn’t have made the modifications had they actually worked, especially since they didn’t even have CHPD and VCC connected and they had the relay firing off of GPIO0 and not GPIO2.

If you have a program that works with the boards without modification, I’d be interested in seeing it. I did search for quite some time for example programs that work with these boards, but without an actual part number for the board and just searching for “ESP-01 Relay” returns hundreds of results.

Even after messing around with them some yesterday another problem is using GPIO2 to fire the relay is that one boot up, it activates the relay. This isn’t good because on a power failure and restoration, the relay is going to activate, probably at a time when you don’t want the relay to activate. There is no overcoming this since the ESP-01 does this with no way to change it. Probably the best course of action would be to use GPIO1 (TX) to fire the relay instead. Which is just a simple matter of moving the jumper.

I found the manufacturer's web page for that module: http://www.chinalctech.com/index.php?_m=mod_product&_a=view&p_id=1253 A lot information. Espressif apps: http://espressif.com/en/support/download/apps (looks like source files) https://www.hackster.io/makerrelay/esp8266-wifi-5v-1-channel-relay-delay-module-iot-smart-home-e8a437

Here's the information to read:

Go to ---> https://www.aliexpress.com/item/ESP8266-5V-WiFi-relay-module-Things-smart-home-remote-control-switch-phone-APP-ESP-01/32821697306.html

Click on the Feedback tab further down on the web page. Read the post by AliExpress Shopper dated October 16, 2017.

Also read post #72567 http://www.esp8266.com/viewtopic.php?p=72567#p72567

.