Esp-01 semi-working access point

loaded the wifiaccesspoint example into esp-01, it shows up with full signal on all devices but i cant connect to it on windows. i can connect to it on android, but the page doesnt load lol

@henriquegarciar, your topic has been moved to a more suitable location on the forum. Installation and Troubleshooting is not for problems with your project :wink: See About the Installation & Troubleshooting category.

That's bad.
How do You think we can help You? Cry together?

Sharpen up and provide facts, information!

You can read the first topic telling how to get the best from this forum. This way You get nothing different than this.

I use Linux (Mint). :grin:

I tried both the current update of the library and the 2.4.2 one, tried a lot of flashing options like cpu speed (80 and 160mhz), flash size 1MB variants(fs:256k, 192k, no fs), flash speed (40 and 80). to run im hooking vcc and cp_en to 3.3v and gnd to gnd, from arduino board. idk if that helps, since the code is loading fine

HARDWARE issues require schematics
SOFTWARE issues require code.

Please determine your issue and provide the needed information.

Over the years I have started to come to the conclusion that when God Created woman from the rib of Man He used the rib that gave Man the ability to read minds. And, since this forum is supported by mostly men, we actually need the details.

I hope you take our posts as a bit of fun mixed with reality.

To offer actual help
Read the beginners guide to the ESP8266.
Lots of information on using it as an access point

circuit
thats the circuit im using to run it, also tried with a 600mah bat. for the code you go to examples > Esp8266Wifi > WifiAcessPoint.

OK, you need to explain exactly what steps you have taken in each case.

I suspect you using the abysmally awful Windoze 10 which makes this all as difficult as possible.

I have just tried that code and it works if you follow the instructions on Android or Mint. Mind you I am not using Windoze.
By the by, if you propose to use ESP-01s, - and I do like them, :grin: I recommend you obtain the proper support tools:


To program the ESP-01, you use a purpose-built USB programming adapter which works perfectly with the Arduino IDE:
Aliexpress item
At least, that is the manual switching version; I would recommend in preference the automatic version which while it does include the reset button, initiates the programming directly from the Arduino IDE:
Aliexpress item
Similarly, to actually use the ESP-01 in a project, a very convenient way and vastly preferable to using the 3.3 V on the UNO is with the cheaper adapter board, plugged into a USB "phone charger" so you have both the 5 V and 3.3 V conveniently and adequately supplied.
Aliexpress item
You have three GPIO conveniently available by soldering to the adapter, and the fourth - serial Rx - can be separated from the USB chip if necessary by cutting a track. Using those I/O you can connect port expanders for many more I/O connections and a variety of sensors.

im doing the classic way of using uno as serial adapter, then unplugging the unecessary cables to run, which used to work perfectly in the past. i also thought it could be wincancer 10 problem but im having problem loading the page in android(it connects easily thou). I was wondering if the chip could be "kinda broken", or such thing is not possible idk

Extremely unlikely

OK, you need to explain exactly what steps you have taken in each case.

What are you using for level shifting?

I do suggest you chase up the proper adapters I mentioned. Makes it so much easier. :sunglasses:

Classic? It sounds completely foreign to me. But what do I know? I've only programmed dozens of dozens of ESP boards over the past few years.

What are you trying to accomplish here? Your "schematic" just shows the Uno being used as a power supply. Which shouldn't work since the Uno 3.3V pin is rated at 50mA, and the ESP will draw at least 80mA.

Has worked for me for a few years without issue.

Good question, and let me add.
Connect the RST pin to VCC as well.

What IP address is it supposed to serve ?

192.168.4.1

What did you find that covers Android?

i said that i tried with a 600mah battery and also didnt work :slight_smile:
btw that was the running circuit, the programing is this one

Your voltage divider in post #15 is in the wrong line; it should be between Arduino TX and ESP RX. See post #18.

So, go back to reply #8. As I suspected, you are trying to do this the hard way.

Unless "the classic way of using UNO as serial adapter" is a lesson in doing this the hardest way possible.

No it's not. For programming you load an empty sketch onto the UNO , connect TX to TX and RX thru divider to RX as is shown. I would use a little less than 2.2K but it should be OK. In fact you have succeeded at uploading, right ?

So is this the code you loaded ?

#include <ESP8266WiFi.h>
#include <WiFiClient.h>
#include <ESP8266WebServer.h>

/* Set these to your desired credentials. */
const char *ssid = "ESPap";
const char *password = "thereisnospoon";

ESP8266WebServer server(80);

/* Just a little test message.  Go to http://192.168.4.1 in a web browser
   connected to this access point to see it.
*/
void handleRoot() {
  server.send(200, "text/html", "<h1>You are connected</h1>");
}

void setup() {
  delay(1000);
  Serial.begin(115200);
  Serial.println();
  Serial.print("Configuring access point...");
  /* You can remove the password parameter if you want the AP to be open. */
  WiFi.softAP(ssid, password);

  IPAddress myIP = WiFi.softAPIP();
  Serial.print("AP IP address: ");
  Serial.println(myIP);
  server.on("/", handleRoot);
  server.begin();
  Serial.println("HTTP server started");
}

void loop() {
  server.handleClient();
}

Can you show me a good close up of the unit you have ? I need to be able to read what is on the flash-chip. Otherwise get a magnifying glass and tell us what is written on it. (the flash chip is the IC with 8 pins)
It is possible that you have an ESP 8285. That would upload just fine but does not work if uploaded with code for 8266.
Try just the default settings for uploading, and if the PCB is black, you can change the flash size to 1MB (though 512kb works just fine)
Try all 4 'flash-mode' settings (default is QIO)

1 Like

Thanks for that, should have noticed that the Uno is just a USB-to-TTL converter. Corrected.

And just to make that easier, this is it!
What I have been working from.

Notably, Android does not (and it certainly does not for me) work with mDNS which I believe would solve this problem. :face_with_raised_eyebrow: It's certainly working nicely in my current project, the scrolling door sign. :grin: