ESP 12-E e Arduino IDE 1.8 / 2.0.0

Sto provando per la prima volta il modulo WiFi ESP 12E, ho scritto il programma controllato che sia giusto solo che ho 2 problemi diversi nelle 2 versioni dell'ide.

Provando ad usare la beta dell'ide2.0.0 riesco a compilare il programma e a caricarlo sul modulo solo che non si forma alcuna porta di rete; mentre utilizzando la versione 1.5 dell'ideriesco a trovare la "porta di rete" ma non riesco a caricare alcun programma.

Ho controllato e ho inserito tutte le librerie necessarie compreso il download di eventuali driver, gestore di schede e inserimento dell'URL all'interno delle impostazioni.

Aiutino?

P.S tutti i componenti sono perfettamente funzionanti

Buongiorno e benvenuto, :slight_smile:
essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con molta attenzione tutto il succitato REGOLAMENTO ... Grazie. :slight_smile:

Guglielmo

P.S.: Ti ricordo che, purtroppo, fino a quando non sarà fatta la presentazione nell’apposito thread, nel rispetto del suddetto regolamento nessuno ti risponderà, quindi ti consiglio di farla al più presto. :wink:

1 Like

Sulla 2.0 ti dico sono che è ancora moooolto in beta e che io me ne sto tenendo alla larga, mentre per l'IDE clasico, l'utima versione ufficiale è la 1.8.15 che devi scaricare da QUI (se sei sotto Win ti consiglio la versione .zip e NON l'eseguibile) e poi installare, dalle preferenze del IDE, il core per gli ESP8266.

Mai avuto alcun problema ... :roll_eyes:

Guglielmo

Ah, dimenticavo ... nella sezione in lingua Inglese, si può scrivere SOLO in Inglese ... quindi, per favore, la prossima volta presta più attenzione in quale sezione metti i tuoi post; questa volta esso è stato spostato, da un moderatore della sezione di lingua Inglese, nella sezione di lingua Italiana ... la prossima volta potrebbe venire direttamente eliminato ::slight_smile:

Guglielmo

1 Like

Si si la versione che uso è la 1.8.15 solo che non riesco a identificare la causa del problema, anzi per questo sembra che addirittura funzioni meglio la versione beta, non riesco a capire.
Tra l'altro da una parte non funziona una cosa che nell'altra versione funziona e viceversa

Ma l'ESP12E come è collegato al PC? E di che porta di rete stai parlando?