ESP errors but not with MEGA

After upgrading from 1.8.5 to 1.8,12 to attempt to work with an ESP32 Dev Module, my currently working sketch (created with 1.8.5 returned the following error message, text file attached below. If I select an Arduino Mega or Mega 2560 board, the sketch compiles with no errors?

Arduino 1.8.12 compile error.txt (35.3 KB)

TOPIC SPLIT !

Is the library you are attempting to use compatible with other architectures as the MCU's are completely different !

Could you take a few moments to Learn How To Use The Forum. Other general help and troubleshooting advice can be found here. It will help you get the best out of the forum in the future.