ESP8266-01/ Brauche Hilfe

Hallo,

was sagt denn der Anbieter dazu? Ich habe da nur das gefunden:

Kompaktes Shield / Erweiterung mit Relais für ESP-01 und ESP-01S Module.

ESP-01 Modul aufstecken und schon ein kompaktes WLAN/WIFI 1 Kanal Relais nutzen.

Das bezweifle ich mal. Sie scheinen einfach nur eine Sammlung Module anzubieten, über Nutzung usw. muß such wohl der Anweder selber Gedanken machen, zumindest konnte ich dort nichts entdecken.

Zum Thema ESP8266-01 findet man genug im Netz, on es für das Relaismodul etwas gibt (Schaltplan z.B. um herauszufinden, an welchem GPIO des ESP8266 das Relais angesteuert wird und ob es bei Low oder High-Pegel anzieht.

Der dort angebotene USB-Programmieradapter für die ESP8266-01 Module ist aus meiner Sicht auch nur bedingt brauchbar. Wenn man den ESP8266 z.B. mit eigener Software programmieren will, sollte man noch 2 Taster an Reset und GPIO0 des ESP-Moduls nachrüsten, um den ESP8266 sinnvoöö in den Programmiermode zu bekommen.

Gruß aus Berlin Michael

Danke für die Antwort.

  1. Gibt es einen Code für das Relais?

  2. Ich habe schon versucht das Modul zu programmieren, es bleibt aber wie "stecken" und startet nicht richtig. Man sieht es am Handy nicht und die blaue LED auf dem Board leuchtet auch nicht...

Hallo,

ICENICE92: 1. Gibt es einen Code für das Relais?

  1. Ich habe schon versucht das Modul zu programmieren, es bleibt aber wie "stecken" und startet nicht richtig. Man sieht es am Handy nicht und die blaue LED auf dem Board leuchtet auch nicht...

Gibt es, da ich das Modul nicht selbst kenne, habe ich keine direkte Empfehlung. Es gibt aber vermutlcih Unmengen an Bespielen, wie man ein Relaismodul mit einem ESP8266 ansteuert.

Wie und womit hat Du versucht, den ESP8266-01 zu programmieren und mit welchen Programm?

Gruß aus Berlin Michael

Oh habe es mit einem Arduino UNO versucht. Es hat funktioniert. Über das Arduino konnte ich auch ein Firmware Update machen. Ich habe die Pins vom ESP8266-01 mit den Pins vom Arduino mithilfe einer Anleitung angeschlossen.

Hallo,

ICENICE92: Oh habe es mit einem Arduino UNO versucht. Es hat funktioniert. Über das Arduino konnte ich auch ein Firmware Update machen. Ich habe die Pins vom ESP8266-01 mit den Pins vom Arduino mithilfe einer Anleitung angeschlossen.

ok, kann man machen, wenn denn funktioniert hat... Ich kenne die Anleitung nicht und traue dem nur bedingt (Stromaufnahme des ESP-Moduls bei 3,3V, Pegekwandler für zumindest den RX-Eingang am ESP usw.).

Aber egal. Was hast Du denn für eine Firmware geupdated? Hast Du denn eine, mit der Du das Relaisboard ansteuern kannst? Tsmota könnte gehen, ist aber wohl wegen des 1MB Flashs des ESP8266-01 etwas tricky. Ich programmieren meinen Kram für die ESPs generelle selber, insofern kann ich da wenig Tipps geben. ESP8266 Erweiterung in der ArduinoIDE installieren (nimm die v2.4.2, nicht die 2.5.0!), schau Dir die beiliegenden Demos-Sketche an oder so. Zumindest wenn Du Spaß am Programmieren hast...

Gruß aus Berlin Michael

Ok, werde ich versuchen.

Ich habe es jetzt nochmal versucht. Es geht immer noch nicht... :disappointed_relieved: :disappointed_relieved:

Oh habe es mit einem Arduino UNO versucht. Es hat funktioniert. Über das Arduino konnte ich auch ein Firmware Update machen.

Dann scheint ja die Grundfunktion vorhanden zu sein!

Kommen denn die Bootmeldungen des ESP?

Bau ein eigenes Programm, mit eigenen Meldungen, dann sagt es dir, wo es klemmt.

Wie kann ich so ein Programm "machen"?

ICENICE92:
Wie kann ich so ein Programm “machen”?

Dieses Werkzeug schon gefunden?

Ja, habe ich

ICENICE92: Ja, habe ich

Sorry, aber deine Aussagen sind etwas wirr und nicht verständlich. In Post #9 schreibst du, es funktioniert. Dann schreibst du kurz darauf, es funktioniert nicht. Dann wiederum fragst du, wie man ein Programm "macht".

Du weist hoffentlich was du willst und womit. Ich werde da jedenfalls nicht schlau draus. Du scheinbar auch nicht.

Es hat funktioniert, das ESP8266-01 mit dem Arduino UNO zu programmieren.

Auf dem ESP leuchtet aber nur die rote LED.

Nur manchmal leuchtet die blaue LED aber nur sehr schwach.

Auf dem Relais-Board leuchtet die LED nicht.

Am Handy zeigt es das WLAN nicht an.

Ich konnte die Firmware aktualisieren.

Gut....und immer so weiter. Welche Firmware ?

Hast du die selbst geschrieben ? Wie hast du die geflasht ? Was hast du alles angeschlossen ? Wie hast du es angeschlossen ?

Zeige deinen Sketch. Zeige dein Schaltbild.

Welche Firmware ? https://www.electrodragon.com/w/File:V1.3.0.2_AT_Firmware.bin.zip

Hast du die selbst geschrieben ? Nein

Wie hast du die geflasht ? Mit ESP8266 Flasher

Was hast du alles angeschlossen ? TXD / CH_PD / VCC / RXD / GPIO0 / GND

Wie hast du es angeschlossen ? Über ein Breadboard zum Arduino UNO (VCC = 3,3 Volt)

Sketch: Anhang

Schaltbild: Anhang

ESP-01S Relay v4.0.pdf (18.6 KB)

ESP8266-WiFi-Relay.ino (12.4 KB)

Ok....soweit gut, oder auch nicht. Wieso machst du es mal mit dem ESPFlasher und mal mit dem Uno ?

Hast du eine Idee, was die Firmware bewirken soll/kann ?

ESPflasher ist das Programm, welches über das Arduino das ESP8266-01 Programmiert/Updated.

Von der Firmware weiss ich nicht, ob es die richtige ist...

Welche Firmware und Sketch soll ich verwenden, dass es funktioniert?

Hallo ;

ich kann Dir erst mal die Seite empfehlen

http://stefanfrings.de/esp8266/index.html

Dann brauchst du meiner Meinung nach einen geeigneten Adapter damit du Sketche vernünftig auf das Ding bekommst.

Adapter

Heinz

Hmmm ....

Ich würde vermuten dass dich erst die Befriedigung deiner Erwartungshaltung glücklich machen wird.

Wie kann ich dir dabei helfen?


Wenn du sagst: "Neue Firmware ist drauf!" Dann solltest du mit dem ESP über AT-Kommando Interface reden können .

Auch solltest du die gesamte Infrastruktur vor dir haben, um die Bootmeldungen anzuzeigen/auszuwerten.