ESP8266 01 wifi won't connect using username and password?

I have an odd problem. I had my old hard drive I had arduino on die, and haven't played around with arduino for several months, but decide to start again. I'm rusty but this is a weird problem.

I downloaded the latest arduino 1.8.8 (Windows store 1.8.19.0). Now it seems like my old esp8266 sketches won't connect to my open wifi unless I skip the password.

I can scan for networks and I see my networks so the receiver must be OK. When I try to connect it fails unless I don't send the password. Also it doesn't work if I have a password and send the correct ssid and password

Here's what I found:

const char* ssid = "MyWiFi";
// The SSID (name) of the Wi-Fi network you want to connect to

const char* password = "";
// The password of the Wi-Fi network, tried with and without password based on wifi setup.

WiFi.begin(ssid, password); //Doesn't connect
WiFi.begin("MyWiFi", "My Password"); //Doesn't connect
WiFi.begin("MyWiFi"); or WiFi.begin(ssid); // Connects to the network

I have tried different versions of firmware and reflashed a few times. My esp8266 01 chips are pretty standard and I found what I think are the correct flash settings for my type of chip, but that made no difference. Other types of non wifi sketches work fine and I was able to upload a sketch and connect to the chip via ap mode, so the transmitter works, but the password thing is just weird.

Here's the debug info:
SDK:3.0.0-dev(c0f7b44)/Core:2.5.0-beta1=20499901/lwIP:STABLE-2_1_2_RELEASE/glue:1.0-4-gc434c6f/BearSSL:2398cc6

Connecting to MyWiFi ...
Mode: STA
PHY mode: N
Channel: 1
AP id: 0
Status: 1
Auto connect: 1
SSID (7): MyWiFi
Passphrase (0):
BSSID set: 0
1 2 scandone
no MyWiFi found, reconnect after 1s
wifi evt: 1
STA disconnect: 201
reconnect

Any help would be greatly appreciated. This has me stumped!

Update. It does connect with username and password, but won't connect when using WiFi,Begin with a ssid and a blank password. I guess I can set up an if else routine that only sends the password if it has one, but any wisdom is appreciated.

Check the library .h for a change in syntax. The library was probably updated and included changes. Look in the examples for the library and see how it's now handled.

I uninstalled the windows store version and installed the standard version and it seems to work fine now. Thanks!