ESP8266 12E not recognizing AT commands

hey,
I recently purchased the nodemcu esp8266 12E. I uploaded a program making it function it as an access point and to control an led through its ip address. It worked well. It even worked with the blink program. I then uploaded a program to initiate serial communication with it. And set the baud rate to 9600 baud and the serial monitor to NL & CR.When i typed the command AT, it didnt respond. Just to be sure I tried many other commands in both upper and lower cases and nothing worked.

I then went through some videos and managed to flash it with the latest firmware with the help of ESPlorer. I went well and i successfully updated it. The build version is this
NodeMCU 0.9.6 build 20150704 powered by Lua 5.1.4
lua: cannot open init.lua

After the update it now gives a different response when I type AT. It says

AT // when i typed AT in the serial monitor

AT+CWMODE=?// when i typed the respective command it said the response shown below
stdin:2: '=' expected near 'AT'

. What should I do next to make this respond to AT commands? Please help!

You should re-flash it with the AT firmware not the NodeMCU firmware.

Maybe go get the latest too.

where do I find the AT firmware? I searched in multiple placees.

There are actually two different flavors of the AT firmware. The version provided by the manufacturer of the ESP8266 modules, AI-Thinker, I believe has additional commands for controlling the GPIO but I've not had good luck finding where this firmware is distributed or documentations as their website is in Chinese and seems to be impervious to Google Translate.

The firmware I use instead is the one provided by the creator of the ESP8266, Espressif. They do their releases here:
http://bbs.espressif.com/viewforum.php?f=46
They claim to be doing releases on GitHub now but this seems to actually only be for the RTOS SDK, which doesn't contain AT firmware. Really, the whole thing is quite a mess for a major company that's producing cutting edge hardware. Hopefully they have gotten their act together a bit more with the ESP32.

It seems that recently they have been only releasing the AT fimware as a part of the NONOS releases. The most recent of those is NONOS 2.0.0:
http://bbs.espressif.com/viewtopic.php?t=2451
The AT firmware is located in bin/at

The last release they did of the AT firmware by itself was 1.1, based on NONOS 1.5.4:
http://bbs.espressif.com/viewtopic.php?t=2199

Thanks for doing the leg work Pert I know this was an early mistake I made and finding the stuff was a pita.

Hopefully the OP gets going with it.

EDIT

Think these were the files I ended up using

2 years old now but know they do work.

Also most of the ESP 8266 01's now use the 1M 512k (spiffs) flash and some can be overclocked from inside the IDE.