ESP8266 blynk arduino UNO

i am getting this error
"Failed to disable echo"

I have tried to search the internet and i found solutions online but none of them seems to work
I flashed the ESp8266 with the 0.22 firmware:


AT version: 20 2015 10:04:26)
SDK version:1.0.0
compile time:Mar 20 2015 11:00:32

AT commands works just fine i just cant connect to the internet i think from the ESP. ( i am using a hotspot from a mobile phone)

My code is:

#define BLYNK_PRINT Serial

#include <ESP8266_Lib.h>
#include <BlynkSimpleShieldEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "e82774e2ccda47cbb50b107fc9f8a0f3";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "Android AP";
char pass[] = "12345678";

// Hardware Serial on Mega, Leonardo, Micro...
//#define EspSerial Serial1

// or Software Serial on Uno, Nano...
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(0, 1); // RX, TX

// Your ESP8266 baud rate:
#define ESP8266_BAUD 115200

ESP8266 wifi(&EspSerial);

void setup()
  // Debug console


  // Set ESP8266 baud rate

  Blynk.begin(auth, wifi, ssid, pass);

void loop()

I did connect the ESP8266 like this
Vcc -> 3.3V
CH_PD ->3.3V
RST -> 3.3V
GPIO 0 -> 3.3V via a resistor 2k
GPIO 2 -> 3.3V via a resistor 2k
Tx -> Tx
Rx -> Rx

I tried to connect it like the tutorial on the web but none of them worked with at commands, so i connectet it like this

I am just trying to get this working thanks

Why are you trying to use SoftwareSerial on the hardware UART? You have to connect RX to TX and vice versa. You need a level shifter on the Arduino's TX line, 5V logic will destroy the ESP, that runs @3.3V.
The 3.3V regulator of the UNO is nowhere near powerful enough for the ESP.
It's recommended to use a 10k resistor in series with CH_PD and RST, don't connect them to 3.3V directly.
You don't have to pull GPIO2 high, the internal pull-up resistor will be enabled at boot time.