ESP8266 D1 Wifi board, can't find the port on MAC OS

Hi, and thanks for letting me in your community! I have a problem with my ESP8266 D1 WeMos Wifi card. Trying to connect it to the computer I don’t seem to get it in the Tools>Ports> … It is not their. I tries 2 cables… doesn’t seem to be the problem. I think I installed all required libraries…! I installed Adafruit ESP8266 , Adafruit IO Arduino ( and all the others suggested when I installed the first…like Adafruit MQTT Libraries and more…).
Any ideas?
Thanks a lot in advance…!

When you plug in the board using USB does a new device appear in Device Manager (or the Linux equivalent) ?

This is not affected by libraries etc and does not even need the IDE to be running

thanks for your help, the answer is NO (even with a third cable). I open Disk Utility on my Mac, and here it doesn’t show the D1 card up… the 2 blue led lights come up… but nothing on the computer… (i don’t think…)

Sorry, but I cannot be of any more help as I know nothing about Macs. Do you know anyone with a PC that you plug it into to see if is recognised (no IDE needed) ?

Yes I have my grandfather PC just here :wink: I will try and plug it in just now…

No success, on neither of both his computers…When searching into the “printers and other external…”

Oh now wait… it DOES come up as USB SERIAL… and says no Driver installer… I don’t seems to be able to do anything about it…

I suppose IDE = Driver…?
Also I suppose now I could download the Driver on the PC Windows… but I would prefer to work on my MAC, I have everything else installed on it (ESP8266 libraries etc…) So why doesn’t it come up on a Mac… Maybe a silly protection…

You don’t need the IDE (Integrated Development Environment) to install the driver

In Windows, open the Control Panel and right click on Device Manager and choose Run as administrator. When it opens click View and select Show hidden devices

Plug in the ESP and the display should refresh. Open the Ports (COM & LPT) section and the ESP should show as a COM port. If not then look for another section named Other devices and open that

If you find any devices with a yellow exclamation mark then unplug the ESP and one of them will probably disappear. If so, plug it back in again, right click the device and click Update (or maybe Install) driver and let Windows search for them

Come back if you get stuck anywhere

Thanks very much, it shows up indeed on Windows as “USB Serial” indeed with a yellow caution flag…!

If i try and search for updates or drivers… it fails to find any… (And anyway I am on my grandfathers Window…) I would like to use it on my MAC. Unless this is a step towards configuring it for my MAC!! But thanks a lot!

I would presume that the MAC has a mechanism for identifying badly installed devices and to install a driver for them

I’ve never touched a Mac in my life. And I’m old.

In Windows you open the Device Manager and expand the “Ports (COM & LPT)”

In this screenshot I have a Uno on COM6, a pair of ESP32 boards on COM3 and COM4, and a pair of Wemos D1 Mini boards on COM15 and COM5.


The UART chip on the Wemos device is a CHP340, and this is the driver you need to find. Windows 10 is very good at finding appropriate drivers.

With the Ports expanded, plug in the Wemos. Did you get something like “USB-SERIAL CH340 (COMx)”? That’s the COM port you want to use in the IDE on that computer. It could easily be a different COM port on another PC. And I have absolutely no clue what Mac calls a USB port.

If you have a yellow check mark then you either have a bad driver or a bad Wemos chip. Try another Wemos chip. (They are cheap- I buy mine 5 at a time).

None of these has anything to do with the device driver. If you have a good board and cable, the PC* will detect and install the driver needed.

*Before Windows 10 driver installation was either automatic or a complex chore. Nothing in-between.

It seems that ESP8266 D1 WeMos has CH340G USB-UART converter. You need to install a driver for CH340G. Maybe this article helps you Getting the Wemos D1 Mini board to work on Mac OS 10.13 (High Sierra) | by James Best | Salted Bytes | Medium
You can find the driver there https://kig.re/downloads/CH341SER_MAC.ZIP
Installation instruction is inside.

Thanks to all! It finally works now… It does open in the Port…

However I have a compiling error now I didn’t have before:

“”"""""""""""""""""""""""""
Arduino: 1.6.6 (Mac OS X), Board: “WeMos D1 R1, 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), 4MB (FS:2MB OTA:~1019KB), v2 Lower Memory, Disabled, None, Only Sketch, 230400”

failed MSpanList_Insert 0x2fc000 0x3a92409a388 0x0
fatal error: MSpanList_Insert

runtime stack:
runtime.throw(0x29e50b)
/usr/local/go/src/runtime/panic.go:491 +0xad fp=0x7ffeefbff3d0 sp=0x7ffeefbff3a0
runtime.MSpanList_Insert(0x2bc008, 0x2fc000)
/usr/local/go/src/runtime/mheap.c:692 +0x8f fp=0x7ffeefbff3f8 sp=0x7ffeefbff3d0
MHeap_FreeSpanLocked(0x2b8c00, 0x2fc000, 0x100)
/usr/local/go/src/runtime/mheap.c:583 +0x163 fp=0x7ffeefbff438 sp=0x7ffeefbff3f8
MHeap_Grow(0x2b8c00, 0x8, 0x0)
/usr/local/go/src/runtime/mheap.c:420 +0x1a8 fp=0x7ffeefbff478 sp=0x7ffeefbff438
MHeap_AllocSpanLocked(0x2b8c00, 0x1, 0x0)
/usr/local/go/src/runtime/mheap.c:298 +0x365 fp=0x7ffeefbff4b8 sp=0x7ffeefbff478
mheap_alloc(0x2b8c00, 0x1, 0x12, 0x0)
/usr/local/go/src/runtime/mheap.c:190 +0x121 fp=0x7ffeefbff4e0 sp=0x7ffeefbff4b8
runtime.MHeap_Alloc(0x2b8c00, 0x1, 0x10000000012, 0x103a9)
/usr/local/go/src/runtime/mheap.c:240 +0x66 fp=0x7ffeefbff518 sp=0x7ffeefbff4e0
MCentral_Grow(0x2c0978, 0x0)
/usr/local/go/src/runtime/mcentral.c:197 +0x8b fp=0x7ffeefbff580 sp=0x7ffeefbff518
runtime.MCentral_CacheSpan(0x2c0978, 0x0)
/usr/local/go/src/runtime/mcentral.c:85 +0x167 fp=0x7ffeefbff5b8 sp=0x7ffeefbff580
runtime.MCache_Refill(0x2f8000, 0x12, 0x0)
/usr/local/go/src/runtime/mcache.c:90 +0xa0 fp=0x7ffeefbff5e0 sp=0x7ffeefbff5b8
runtime.mcacheRefill_m()
/usr/local/go/src/runtime/malloc.c:368 +0x57 fp=0x7ffeefbff600 sp=0x7ffeefbff5e0
runtime.onM(0x2188f8)
/usr/local/go/src/runtime/asm_amd64.s:273 +0x9a fp=0x7ffeefbff608 sp=0x7ffeefbff600
runtime.mallocgc(0x120, 0x1b5be0, 0x0, 0x0)
/usr/local/go/src/runtime/malloc.go:178 +0x849 fp=0x7ffeefbff6b8 sp=0x7ffeefbff608
runtime.newobject(0x1b5be0, 0x2f8000)
/usr/local/go/src/runtime/malloc.go:353 +0x49 fp=0x7ffeefbff6e0 sp=0x7ffeefbff6b8
runtime.newG(0x27f1a)
/usr/local/go/src/runtime/proc.go:233 +0x2a fp=0x7ffeefbff6f8 sp=0x7ffeefbff6e0
allocg(0x2ab5e0)
/usr/local/go/src/runtime/proc.c:925 +0x1f fp=0x7ffeefbff708 sp=0x7ffeefbff6f8
runtime.malg(0x8000, 0x2ab680)
/usr/local/go/src/runtime/proc.c:2106 +0x1f fp=0x7ffeefbff738 sp=0x7ffeefbff708
runtime.mpreinit(0x2aba40)
/usr/local/go/src/runtime/os_darwin.c:137 +0x27 fp=0x7ffeefbff750 sp=0x7ffeefbff738
mcommoninit(0x2aba40)
/usr/local/go/src/runtime/proc.c:201 +0xc9 fp=0x7ffeefbff778 sp=0x7ffeefbff750
runtime.schedinit()
/usr/local/go/src/runtime/proc.c:138 +0x55 fp=0x7ffeefbff7a0 sp=0x7ffeefbff778
runtime.rt0_go(0x7ffeefbff7d0, 0x18, 0x7ffeefbff7d0, 0x0, 0x18, 0x7ffeefbff990, 0x7ffeefbff9c8, 0x7ffeefbff9d4, 0x7ffeefbff9e4, 0x7ffeefbff9ee, …)
/usr/local/go/src/runtime/asm_amd64.s:95 +0x116 fp=0x7ffeefbff7a8 sp=0x7ffeefbff7a0
arduino-builder returned 2

Error compiling.

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.
‘’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’’
I would be so great full for any help…

Why don’t you want to read the official manual?
Get started with Arduino [D1/D1 mini series] — WEMOS documentation
You need:

  1. CH340G driver
  2. Arduino IDE
  3. Install esp8266 package
  4. Configure board

thanks I will have a look and read at this… I had found another user manual but not this one… will go through it!! thanks

To help people searching for this solution in the future- which of the suggestions fixed it for you.

Read the directions on how to use this forum.
When you get the error message, click on the “copy error message” button on the IDE, then paste that IN CODE TAGS on the forum.

However, when the compiler tosses a runtime stack, then it has crashed. A compiler crash has nothing to do with your code or device drivers. It means that, possibly, the IDE is not properly installed.

Try loading a sample program, blink.ino, and compile it. Upload it to your Wemos. Watch the LED blink. If you get this far then your IDE and Wemos are good to go. If you can’t even compile, then reinstall the IDE.