ESP8266 D1 Wifi board, can't find the port on MAC OS

thanks I will have a look and read at this… I had found another user manual but not this one… will go through it!! thanks

To help people searching for this solution in the future- which of the suggestions fixed it for you.

Read the directions on how to use this forum.
When you get the error message, click on the “copy error message” button on the IDE, then paste that IN CODE TAGS on the forum.

However, when the compiler tosses a runtime stack, then it has crashed. A compiler crash has nothing to do with your code or device drivers. It means that, possibly, the IDE is not properly installed.

Try loading a sample program, blink.ino, and compile it. Upload it to your Wemos. Watch the LED blink. If you get this far then your IDE and Wemos are good to go. If you can’t even compile, then reinstall the IDE.

Well to be honest I am not to sure what stage made it… i installed many things several times (CH340 driver, libraries for ESP8266, Python…) so i can’t tell at what point it worked… sorry

Ok thanks… when you say: IN CODE TAGS… I don’t see what you mean. I copy then past the code, but WHERE?? (Is it in the Reply text window? With the “Pre-formatted text more” or something…? Thanks…

Please follow the advice given in the link below when posting code

Alternatively Auto format your code in the IDE, select all of it, use Copy for forum in the IDE and paste it here so that it is in code tags to make it easier to read and copy for examination

thanks, so I am following the manual: at the stage where I entered “cd esp8266/tools” in my Terminal, it comes back with the error message: “No such file or directory”… I believe I have followed all previous steps properly. Any help? (I am a beginner I appreciate all your support!).

Oh OK!! I got this:

#include <dummy.h>

#include <ESP8266WiFiGratuitous.h>
#include <WiFiServerSecure.h>
#include <WiFiClientSecure.h>
#include <WiFiClientSecureBearSSL.h>
#include <ESP8266WiFi.h>
#include <ESP8266WiFiMulti.h>
#include <WiFiUdp.h>
#include <ESP8266WiFiType.h>
#include <CertStoreBearSSL.h>
#include <ESP8266WiFiAP.h>
#include <WiFiClient.h>
#include <BearSSLHelpers.h>
#include <WiFiServer.h>
#include <ESP8266WiFiScan.h>
#include <WiFiServerSecureBearSSL.h>
#include <ESP8266WiFiGeneric.h>
#include <ESP8266WiFiSTA.h>
#include <WiFiClientSecureAxTLS.h>
#include <WiFiServerSecureAxTLS.h>

#include <Adafruit_ESP8266.h>

#include <Adafruit_ESP8266.h>

/*************************************************************
  Download latest Blynk library here:
    https://github.com/blynkkk/blynk-library/releases/latest

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials: http://www.blynk.cc
    Sketch generator:           http://examples.blynk.cc
    Blynk community:            http://community.blynk.cc
    Follow us:                  http://www.fb.com/blynkapp
                                http://twitter.com/blynk_app

  Blynk library is licensed under MIT license
  This example code is in public domain.

 *************************************************************

  You can send/receive any data using WidgetTerminal object.

  App project setup:
    Terminal widget attached to Virtual Pin V1
 *************************************************************/

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "niuTDRDLrddB7KUPLu6NqRnEtx_dpcBT";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "FairyLink_98DD66";
char pass[] = "";

// Attach virtual serial terminal to Virtual Pin V1
WidgetTerminal terminal(V1);

// You can send commands from Terminal to your hardware. Just use
// the same Virtual Pin as your Terminal Widget
BLYNK_WRITE(V1)
{

  // if you type "Marco" into Terminal Widget - it will respond: "Polo:"
  if (String("Marco") == param.asStr()) {
    terminal.println("You said: 'Marco'") ;
    terminal.println("I said: 'Polo'") ;
  } else {

    // Send it back
    terminal.print("You said:");
    terminal.write(param.getBuffer(), param.getLength());
    terminal.println();
  }

  // Ensure everything is sent
  terminal.flush();
}

void setup()
{
  // Debug console
  Serial.begin(9600);

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);

  // Clear the terminal content
  terminal.clear();

  // This will print Blynk Software version to the Terminal Widget when
  // your hardware gets connected to Blynk Server
  terminal.println(F("Blynk v" BLYNK_VERSION ": Device started"));
  terminal.println(F("-------------"));
  terminal.println(F("Type 'Marco' and get a reply, or type"));
  terminal.println(F("anything else and get it printed back."));
  terminal.flush();
}

void loop()
{
  Blynk.run();
}

Is that it…? I think so…

Oh WAIT! i was reading the Windows section not the Mac section… I have a clue "If you get an error message stating that python3 is not found, you will need to install it (most modern UNIX-like OSes provide Python 3 as part of the default install). To install you will need to use sudo yum install python3 , sudo apt install python3 , or brew install python3 as appropriate. " I my case only the “apt” works.

Ok now I am stuck again: to “download binary tools” i need to type: cd esp8266/tools python3 get.py. But it fails. So I try to install Python 3 (with sudo apt install python3). It invited me to instal Java JDE which I did. Now i try sudo apt install python3 and this time I have Unable to locate an executable at "/Library/Java/JavaVirtualMachines/jdk-16.0.1.jdk/Contents/Home/bin/apt" (-1). I Manually went into this folder, their isn’t apt indeed… More ideas…?

Installing a package esp8266 package means the following:

  • Start Arduino and open the Preferences window.
  • Enter https://arduino.esp8266.com/stable/package_esp8266com_index.json into the File>Preferences>Additional Boards Manager URLs field of the Arduino IDE. You can add multiple URLs, separating them with commas.
  • Open Boards Manager from Tools > Board menu and install esp8266 platform (and don’t forget to select your ESP8266 board from Tools > Board menu after installation).

Did you do the same?
Do you see your right board in the list of boards in Arduino IDE?Wemos D1 List

Yes all of these steps I think I did successfully… I have [quote=“Boffin, post:27, topic:853450”]
https://arduino.esp8266.com/stable/package_esp8266com_index.json
[/quote], I have selected Board> WeMos D1 R1. When connected to the computer the right port is selected…
NOW: I have deleted my old 1.0.6 version of Arduino. I am now using the 1.8.13! the only error message I have left is fork/exec /bin/xtensa-lx106-elf-g++: no such file or directory Error compiling for board WeMos D1 R1.
Knowing that my D1 ESP8266 board is not connected at the moment, but if I am right this doesn’t mater if I am only compiling the code right…?

And? Don’t pull the rubber please. File → Examples → 01.Basics → Blink
Push Verify button. Wait until Done compiling. What you see?
No need to connect the board at compile time.

“Pull the rubber…??” I just did exactly what you said. Blink and compile… and I have fork/exec /bin/xtensa-lx106-elf-g++: no such file or directory Error compiling for board WeMos D1 R1.… still :wink: (thanks again…)

Unfortunately I am not familiar with macOS. Try to read the official ESP8266 link
Instructions - Other OS.
Maybe problem is in IDE installation or in the compatibility of macOS and Arduino IDE versions.

ok thanks I have followed these instructions. I will search for this error message on the web and see what I find… Until next time! Best

Have you tried reinstalling the IDE?

The IDE is the program Arduino 1.8.13 right? If so I just yesterday installed this last version, but I can try reinstalling it…! > I have done so nothing changed. Now I have tried removing and reinstalling the ESP8266 Board from the Boards Manager… It FAILS, when doing so I get error message in the Boards Manager: java.lang.NullPointerException

Is this happening on the PC or the MAC?
If it’s on a MAC, then say so in the title of the thread. I know of no one running the IDE on a MAC, but maybe if you put it in the thread title, a MAC user may come out of the closet.

If it’s on a PC then we can keep troubleshooting together.

It a MAC. Ok your right I will add it to the title :wink: thanks ! I will get their…

Actually at that stage the topic isn’t the same anymore. If I can I will write another post concerning my new error… thanks to all!