ESP8266 -- Programming errors

I just got the ESP8266 wifi microcontroller and things are pretty weird :o . I uploaded the program to the ESP8266 and it worked out fine, the problem is that it keeps showing an error saying that it fails sending the bytes of data to the microcontroller. The last error that the program outputs is :

Arduino: 1.8.3 (Windows 10), Board: "Generic ESP8266 Module, 80 MHz, 80MHz, DIO, 9600, 512K (64K SPIFFS), nodemcu, Disabled, None"

Archiving built core (caching) in: C:\Users\fabi1\AppData\Local\Temp\arduino_cache_865558\core\core_esp8266_esp8266_generic_CpuFrequency_80,FlashFreq_80,FlashMode_dio,UploadSpeed_9600,FlashSize_512K64,ResetMethod_nodemcu,Debug_Disabled,DebugLevel_None_____7bf77998025c11025b1f3a425ac63de2.a
Sketch uses 222201 bytes (51%) of program storage space. Maximum is 434160 bytes.
Global variables use 31576 bytes (38%) of dynamic memory, leaving 50344 bytes for local variables. Maximum is 81920 bytes.
Uploading 226352 bytes from C:\Users\fabi1\AppData\Local\Temp\arduino_build_559265/Blink.ino.bin to flash at 0x00000000
error: failed sending 1072 bytes
.error: failed sending 1044 bytes
.error: failed sending 1040 bytes
.error: failed sending 1040 bytes
.error: failed sending 1070 bytes
.error: failed sending 1083 bytes
.error: failed sending 1069 bytes
.error: failed sending 1080 bytes
warning: espcomm_send_command: didn't receive command response
warning: espcomm_send_command(FLASH_DOWNLOAD_DATA) failed
warning: espcomm_send_command: wrong direction/command: 0x01 0x03, expected 0x01 0x04
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I've tried it a few more times, cleared the memory space with the "reset" button on the board, but... IT DOESN'T WORK >:(

Are you trying to program the ESP8266 Core for Arduino into a ESP-01?

"...and it worked out fine, the problem is..."

Either it "worked out fine", or there is a problem. It can't be both...

EXACTLY what board do you have? EXACTLY what board do you have selected in the IDE?

Regards,
Ray L.

Do You know how to put the module into programming mode?

I have the ESP8266MOD LoLin NodeMCU Version 3. I selected the example "Blink". The built-in LED blinked after I uploaded the program to the microcontroller, but the mentioned error is the problem.

ieee488:
Are you trying to program the ESP8266 Core for Arduino into a ESP-01?

It says LoLin new ModeMcuV3 ( with ESP8266MOD Core ). I try to program only the microcontroller alone.

OK, so that's HALF of what I asked for....

In the Arduino IDE, I have selected in Boards Manager ESP8266 Vers.2.3.0, then I selected Board:"Generic ESP8266 Module". Thanks for your reply :slight_smile:

OK, what you have is NOT a Generic 8266 board. Try the NODEMCU v1.0.

Regards,
Ray L.

Thank you very much. It works !! :slight_smile: