ESP8266 SmartConfig and Esp-01/esp-01s config problem

I purchased this : Elecrow Newest V4.0 Version ESP8266 ESP 01 ESP 01S Relay Module Remote Switch Phone APP DIY Kit Support ESP01 ESP01S WiFi Module|wifi module|relay modulediy kit - AliExpress

and this: ESP8266 ESP-01

and followed these directions:

  1. Power it by DC 5v;

2.Open your phone WLAN then connect the WiFi ESP8266-XXXX, Power word:12345678

3.Open the ESP8266 Controller.app ( Installed it in your android phone before)

  1. Set IP Address: 192.168.1.1 than you can control your device via the wifi relay module:

I connected it to a power supply: (tried 5 v, 9 v, 12 v) at .5 amp
With my Motorola android I can see "AITHINKER_xxxx and I can connect to it.

With the ESP8266 Smartconfig App I can see the SSID AIthinker:

I tried connecting (confirming) using no password, ai-thinker, and 12345678

No go however !!!! The app first says "esptouch is configuring,please wait for a moment" "waiting"

then it says "esptouch fail/confirm"

What am I doing wrong? I am using this out of the box and did no programming as a thought the app required none.

Thank you

Bill