ESP8266 Won't Compile With 1.8.3 Works With 1.6.5

I have been using version 1.6.5 version if the Arduino IDE for ESP8266 for quite a while. It works great.

I decided I wanted to try the new serial plotter so I installed version 1.8.3. Now, I can’t compile any sketch for ESP8266. I can select the module from the board list, but when I try to compile, I get the following error messages:

Board nodemcuv2 (platform esp8266, package esp8266) is unknown
Error compiling for board NodeMCU 1.0 (ESP-12E Module).

I tried a couple of other boards in the series with the same result.
I restarted the computer before compiling the sketch without any success.

I’m running Windows 10

That’s not a typo, it does say nodemcuv2 in the error message. I wonder if that v2 is a clue to the problem.

I have this problem too!! :confused:

This error indicates that you did an update of ESP8266 core for Arduino via Boards Manager but the Arduino IDE failed to completely remove the previous version of the package.

  • Click the link at the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar name) folder.
  • Navigate to Arduino15/packages/esp8266/hardware/esp8266
  • Here you should see two different version folders, one of which is the previous version you updated from. Delete that folder. Please be very careful when deleting things on your computer. When in doubt, back up!

After doing that the problem should be solved.